aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-12-20 11:07:00 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-12-22 14:08:47 +0800
commit964c0b44cde43c4d42e052a5cad2d14bbbac3281 (patch)
tree30c2ded58bb270de98ca68178a2441d778737556 /gnu/packages/xfce.scm
parent29291e6f624c1ae7e5a73f15e061cdfe706370ee (diff)
downloadguix-964c0b44cde43c4d42e052a5cad2d14bbbac3281.tar.gz
guix-964c0b44cde43c4d42e052a5cad2d14bbbac3281.zip
gnu: xfconf: Update to 4.20.0.
* gnu/packages/xfce.scm (xfconf): Update to 4.20.0. [arguments]: Add 'patch-configure phase for 'gdbus-codegen'. Change-Id: I9b652946796ff65d7fa22338adfcbb6534894169
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c17a76b213..7b6b525cb7 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -135,7 +135,7 @@ Xfce Desktop Environment.")
(define-public xfconf
(package
(name "xfconf")
- (version "4.18.3")
+ (version "4.20.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -143,12 +143,18 @@ Xfce Desktop Environment.")
"xfconf-" version ".tar.bz2"))
(sha256
(base32
- "165xbr6y5z4zr235znkqlwkcy2ib9hgfqrdic0n7p57nas8ccv65"))))
+ "1zbyar9hzvqf498z1a3q6kf6r77a6qm9x2gw6p7i6sviy5h3ri4b"))))
(build-system gnu-build-system)
(arguments
'(#:phases
;; Run check after install phase to test dbus activation.
(modify-phases %standard-phases
+ (add-before 'configure 'patch-configure
+ (lambda _
+ (substitute* "configure"
+ ;; XDG_CHECK_PACKAGE_BINARY requires an absolute path.
+ (("\\$PKG_CONFIG --variable=gdbus_codegen gio-2.0")
+ "type -p gdbus-codegen"))))
;; tests-end seems to hang forever
(add-before 'configure 'patchout-tests-end
(lambda _