aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:47:59 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:50:12 +0800
commit8a3c54e0a14b74dabe48943c25fd711d32e91f31 (patch)
tree2e33d96d57963fc153669c68d9a6b7d4499ef5fa /gnu/packages/xfce.scm
parent3a4bfddee736ee73ed0e06347768051c3cbd5f73 (diff)
downloadguix-8a3c54e0a14b74dabe48943c25fd711d32e91f31.tar.gz
guix-8a3c54e0a14b74dabe48943c25fd711d32e91f31.zip
gnu: Add xfdesktop.
* gnu/packages/xfce.scm (xfdesktop): New variable.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index aaf4b600f6..f715a50b7b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -444,3 +444,34 @@ and import the new pictures from your camera.")
"Window manager for Xfce, it handles the placement of windows
on the screen.")
(license gpl2+)))
+
+(define-public xfdesktop
+ (package
+ (name "xfdesktop")
+ (version "4.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/xfce/"
+ (version-major+minor version)
+ "/src/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0yrddj1lgk3xn4w340y89z7x2isks72ia36pka08kk2x8gpfcyl9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("exo" ,exo)
+ ("garcon" ,garcon)
+ ("libnotify" ,libnotify)
+ ("libwnck" ,libwnck-1)
+ ("libxfce4ui" ,libxfce4ui)
+ ("thunar" ,thunar)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Xfce desktop manager")
+ (description
+ "Desktop manager for Xfce, it sets the background color or image with
+optional application menu or icons for minimized applications or launchers,
+devices and folders.")
+ (license gpl2+)))