aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2014-12-05 00:22:04 +0300
committerAlex Kost <alezost@gmail.com>2014-12-10 00:37:46 +0300
commit2e88e089da7cb0d1937e020ce1f7efdf72739a74 (patch)
tree860193750c4368c0671c79377ac5d35c6390a974 /gnu/packages/xdisorg.scm
parent426fde9ae1e9869a295764da5936d5a085c12ed3 (diff)
downloadguix-2e88e089da7cb0d1937e020ce1f7efdf72739a74.tar.gz
guix-2e88e089da7cb0d1937e020ce1f7efdf72739a74.zip
gnu: Add wmctrl.
* gnu/packages/xdisorg.scm (wmctrl): New variable. * gnu/packages/patches/wmctrl-64-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a118fd745e..a46b8f8fac 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +28,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages xorg))
;; packages outside the x.org system proper
@@ -215,3 +217,37 @@ notification protocol. The reference implementation is mostly under an X Window
System style license, and has no special dependencies.")
;; Most of the code is provided under x11 license.
(license license:lgpl2.0+)))
+
+(define-public wmctrl
+ (package
+ (name "wmctrl")
+ (version "1.07")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://tomas.styblo.name/wmctrl/dist/wmctrl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1afclc57b9017a73mfs9w7lbdvdipmf9q0xdk116f61gnvyix2np"))
+ (patches (list (search-patch "wmctrl-64-fix.patch")))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list (string-append "--mandir="
+ (assoc-ref %outputs "out")
+ "/share/man"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxmu" ,libxmu)
+ ("glib" ,glib)))
+ (home-page "http://tomas.styblo.name/wmctrl/")
+ (synopsis "Command-line tool to control X window managers")
+ (description
+ "Wmctrl allows to interact with an X window manager that is compatible
+with the EWMH/NetWM specification. It can query the window manager for
+information, and request for certain window management actions (resize and
+move windows, switch between desktops, etc.)")
+ (license license:gpl2+)))