aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2023-10-27 09:46:04 -0400
committerChristopher Baines <mail@cbaines.net>2023-10-30 11:17:43 +0000
commit85451b38dd175f8bd4bcb42336c895bdc9373d28 (patch)
tree763df1f2387c1b5f3569d71c2f284bd668712d10 /gnu/packages/wm.scm
parent4af23bc03c1e05a4f8275e53a61a702ca708c251 (diff)
downloadguix-85451b38dd175f8bd4bcb42336c895bdc9373d28.tar.gz
guix-85451b38dd175f8bd4bcb42336c895bdc9373d28.zip
gnu: ansible: Update to 8.5.0.
* gnu/packages/admin.scm (ansible): Update to 8.5.0. Change-Id: I38ac84a0945f3ba10e13246cf8ae95c3795b52b3 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/wm.scm')
0 files changed, 0 insertions, 0 deletions
kages/databases.scm
@@ -61,6 +61,7 @@
;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Felix Gruber <felgru@posteo.ne
;;; Copyright © 2023 Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3113,6 +3114,48 @@ engraved in its design that you are working not with just tables, you work
with relational data.")
(license license:asl2.0)))
+(define-public aerich
+ (package
+ (name "aerich")
+ (version "0.7.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tortoise/aerich")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pcy945bg890p12s7cyw0mg7hxwsxyy570j600sbf7kwj2d3lilg"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list poetry
+ python-bandit
+ python-cryptography
+ python-isort
+ python-pydantic
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-mock
+ python-pytest-xdist))
+ (propagated-inputs
+ (list python-asyncmy
+ python-asyncpg
+ python-click
+ python-ddlparse
+ python-dictdiffer
+ python-tomlkit
+ python-tortoise-orm))
+ (home-page "https://github.com/tortoise/aerich")
+ (synopsis "Database migrations tool for Tortoise @acronym{ORM, Object Relational
+Mapper}")
+ (description
+ "This package provides @code{aerich}, a Python database migrations tool
+for Tortoise @acronym{ORM, Object Relational Mapper}. It can be used both
+programmatically or as a standalone CLI application.")
+ (license license:asl2.0)))
+
(define-public sqlcipher
(package
(name "sqlcipher")