aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-09 16:44:22 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-09 16:46:34 +0100
commit6cae1db889f62051580d5a365f62585412a53a8c (patch)
tree4d3db074d50ca3e2109cced17bec77f207a0c1fd /gnu/packages/wm.scm
parent410e699e0933653e69d03a4cdadf11854c6723f4 (diff)
parent35e1d9247e39f3c91512cf3d9ef1467962389e35 (diff)
downloadguix-6cae1db889f62051580d5a365f62585412a53a8c.tar.gz
guix-6cae1db889f62051580d5a365f62585412a53a8c.zip
Merge remote-tracking branch 'savannah/master' into mesa-updates
Change-Id: Iad185e2ced97067b3dff8fd722435a6c5e2c00e5
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm24
1 files changed, 18 insertions, 6 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 588b62516e..4e76e705e1 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -797,7 +797,7 @@ desktop environment.")
(define-public icewm
(package
(name "icewm")
- (version "3.4.6")
+ (version "3.4.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -805,7 +805,7 @@ desktop environment.")
version "/icewm-" version ".tar.lz"))
(sha256
(base32
- "1j4jd1fim12h8ry7jkx6y298kyn63pabih1m61rljbzvr3lyy1db"))))
+ "0c1c9qwaq9kdlma5kfqzjzzm6wk3bww6b7mw4b3j76fn7ms4982s"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config))
(inputs (list fontconfig
@@ -1852,7 +1852,7 @@ narrow the items to those matching the tokens in the input.")
(package
(inherit sway)
(name "swayfx")
- (version "0.3.1")
+ (version "0.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1861,8 +1861,20 @@ narrow the items to those matching the tokens in the input.")
(file-name (git-file-name name version))
(sha256
(base32
- "1550n9xnqbl1am4cwlnj8ip5cs7kgdzx96ga2hkcw29cpyian7rv"))))
+ "13d8icd45j937jgkidr7cyjys4nnvxh4ilp7ml0i2ml39ipv01qv"))))
(build-system meson-build-system)
+ (inputs (list basu
+ cairo
+ gdk-pixbuf
+ json-c
+ libevdev
+ libinput-minimal
+ libxkbcommon
+ pango
+ pcre2
+ swaybg
+ wayland
+ wlroots-0.16))
(home-page "https://github.com/WillPower3309/swayfx")
(synopsis "Sway Fork with extra options and effects")
(description
@@ -3195,7 +3207,7 @@ read and write, and compatible with JSON.")
(define-public labwc
(package
(name "labwc")
- (version "0.7.0")
+ (version "0.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3204,7 +3216,7 @@ read and write, and compatible with JSON.")
(file-name (git-file-name name version))
(sha256
(base32
- "17p3wcnggnd4v37z1dgv8nmc35nq4261s8sglr44bf71vjircggz"))))
+ "09j6p4p2c00rpcr65r6igj0llfablg5j2d1ys87kyh858dhajpza"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config gettext-minimal scdoc))