aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
commit533a893cc6b03f100566760d6e0c8e0500ed7082 (patch)
tree0ecbf89895a400c43d16bb1f6539f1a88aeaa4cf /gnu/packages/wm.scm
parent6a2546f92d07df04e5d700924edd027ed1e2ef11 (diff)
parentc762df54786fd6f005f3b5307323f1d2df3cbf0b (diff)
downloadguix-533a893cc6b03f100566760d6e0c8e0500ed7082.tar.gz
guix-533a893cc6b03f100566760d6e0c8e0500ed7082.zip
Merge branch 'master' into staging
Conflicts: .guix-authorizations gnu/ci.scm gnu/packages/base.scm gnu/packages/databases.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/imagemagick.scm gnu/packages/password-utils.scm gnu/packages/python-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm150
1 files changed, 124 insertions, 26 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8e3b4244ce..4df1af27cb 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Noodles! <nnoodle@chiru.no>
;;; Copyright © 2019, 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
-;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Boris A. Dekshteyn <harlequin78@gmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
@@ -39,9 +39,11 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
+;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -160,14 +162,14 @@ the leaves of a full binary tree.")
(define-public herbstluftwm
(package
(name "herbstluftwm")
- (version "0.8.3")
+ (version "0.9.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://herbstluftwm.org/tarballs/herbstluftwm-"
version ".tar.gz"))
(sha256
- (base32 "1qmb4pjf2f6g0dvcg11cw9njwmxblhqzd70ai8qnlgqw1iz3nkm1"))
+ (base32 "0avfhr68f6fjnafjdcyxcx7dkg38f2nadmhpj971qyqzfq2f6i38"))
(file-name (string-append "herbstluftwm-" version ".tar.gz"))))
(build-system cmake-build-system)
(inputs
@@ -180,10 +182,12 @@ the leaves of a full binary tree.")
("libx11" ,libx11)
("libxext" ,libxext)
("libxinerama" ,libxinerama)
- ("libxrandr" ,libxrandr)))
+ ("libxrandr" ,libxrandr)
+ ("libxft" ,libxft)))
(native-inputs
`(("asciidoc" ,asciidoc)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
(arguments
'(#:tests? #f
#:configure-flags
@@ -318,7 +322,6 @@ commands would.")
("libxkbcommon" ,libxkbcommon)
("libev" ,libev)
("libyajl" ,libyajl)
- ("asciidoc" ,asciidoc)
("xmlto" ,xmlto)
("perl-pod-simple" ,perl-pod-simple)
("libx11" ,libx11)
@@ -330,6 +333,7 @@ commands would.")
`(("which" ,which)
("perl" ,perl)
("pkg-config" ,pkg-config)
+ ("asciidoc-py3" ,asciidoc-py3)
;; For building the documentation.
("libxml2" ,libxml2)
("docbook-xsl" ,docbook-xsl)))
@@ -1262,7 +1266,7 @@ project derived from the original Calm Window Manager.")
(define-public dwl
(package
(name "dwl")
- (version "0.1")
+ (version "0.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1271,7 +1275,7 @@ project derived from the original Calm Window Manager.")
(file-name (git-file-name name version))
(sha256
(base32
- "18g2sx8cv54zl5iw5m9lzngrp6ra2pyp7c68qps2ava3brw9m0j2"))))
+ "0r5hsxpckkrq1y7bjfq58rlc5xy45z499rg628q3nh289978ail1"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1281,12 +1285,7 @@ project derived from the original Calm Window Manager.")
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure
- (replace 'install ; no install target
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (install-file "dwl" bin)))))))
+ (delete 'configure)))) ; no configure
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -1346,14 +1345,14 @@ its size
(define-public polybar
(package
(name "polybar")
- (version "3.5.4")
+ (version "3.5.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/polybar/polybar/releases/"
"download/" version "/polybar-" version ".tar.gz"))
(sha256
- (base32 "0awwjp3l0y9yhmrl914710ipawp2xr43jxrvmnanahlznblg8fhk"))))
+ (base32 "1c8br9972x1qw7l2shj9aqzv0gsx58fdh3r0f1z5i1bqdwxmsqky"))))
(build-system cmake-build-system)
(arguments
;; Test is disabled because it requires downloading googletest from the
@@ -1570,7 +1569,7 @@ modules for building a Wayland compositor.")
(define-public waybar
(package
(name "waybar")
- (version "0.9.4")
+ (version "0.9.5")
(source
(origin
(method git-fetch)
@@ -1579,10 +1578,10 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "038vnma7y7z81caywp45yr364bc1aq8d01j5vycyiyfv33nm76fy"))))
+ (base32 "1kzrgqaclfk6gcwhknxn28xl74gm5swipgn8kk8avacb4nsw1l9q"))))
(build-system meson-build-system)
(inputs `(("date" ,date)
- ("fmt" ,fmt-6)
+ ("fmt" ,fmt)
("gtk-layer-shell" ,gtk-layer-shell)
("gtkmm" ,gtkmm)
("jsoncpp" ,jsoncpp)
@@ -1591,7 +1590,7 @@ modules for building a Wayland compositor.")
("libmpdclent" ,libmpdclient)
("libnl" ,libnl)
("pulseaudio" ,pulseaudio)
- ("spdlog" ,spdlog-1.7)
+ ("spdlog" ,spdlog)
("wayland" ,wayland)))
(native-inputs
`(("gcc" ,gcc-8) ; for #include <filesystem>
@@ -1786,8 +1785,8 @@ productive, customizable lisp based systems.")
(delete 'cleanup)))))))
(define stumpwm-contrib
- (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d63")
- (revision "2"))
+ (let ((commit "a7dc1c663d04e6c73a4772c8a6ad56a34381096a")
+ (revision "3"))
(package
(name "stumpwm-contrib")
(version (git-version "0.0.1" revision commit)) ;no upstream release
@@ -1799,7 +1798,7 @@ productive, customizable lisp based systems.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0giac390bq95ag41xkxqp8jjrhfx1wpgglz7jg5rkm0wjhcwmyml"))))
+ (base32 "09akdaaya7lga5lzbq1aj1filsyjwvflghkidpmr0nk0jz5xx1g7"))))
(build-system asdf-build-system/sbcl)
(inputs
`(("stumpwm" ,stumpwm "lib")))
@@ -2022,6 +2021,26 @@ layouts in StumpWM.")
(description "Modeline support for CPU info.")
(license license:gpl3+)))
+(define-public sbcl-stumpwm-disk
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-disk")
+ (arguments
+ '(#:asd-systems '("disk")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "modeline/disk") #t)))))
+ (inputs
+ `(("stumpwm" ,stumpwm "lib")
+ ("cl-diskspace" ,sbcl-cl-diskspace)
+ ("cl-mount-info" ,sbcl-cl-mount-info)))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "StumpWM modeline support to show disk usage")
+ (description "StumpWM modeline support to show disk usage")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public sbcl-stumpwm-mem
(package
(inherit stumpwm-contrib)
@@ -2328,7 +2347,7 @@ shows a notification for the user on the screen.")
(define-public cagebreak
(package
(name "cagebreak")
- (version "1.4.4")
+ (version "1.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2337,7 +2356,7 @@ shows a notification for the user on the screen.")
(file-name (git-file-name name version))
(sha256
(base32
- "0mnxs1m7jrqdl0asx39nxfzvkp7d4jqpdchi63w2yd1igpj2frb2"))))
+ "02gxmypfj75amdd8lwdkkk7imw7lwmghpyk8h9asljy9aq6ymdqp"))))
(build-system meson-build-system)
(arguments '(#:configure-flags '("-Dxwayland=true")))
(native-inputs
@@ -2353,3 +2372,82 @@ shows a notification for the user on the screen.")
for wayland conceptually based on the X11 window manager
@command{ratpoison}.")
(license license:expat)))
+
+(define-public libucl
+ (package
+ (name "libucl")
+ (version "0.8.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vstakhov/libucl/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h52ldxankyhbbm1qbqz1f2q0j03c1b4mig7343bs3mc6fpm18gf"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests
+ (home-page "https://github.com/vstakhov/libucl")
+ (synopsis "Universal configuration language (UCL) parser")
+ (description "libucl implements a configuration language that is easy to
+read and write, and compatible with JSON.")
+ (license license:bsd-2)))
+
+(define-public hikari
+ (package
+ (name "hikari")
+ (version "2.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hikari.acmelabs.space/releases/"
+ "hikari-" version ".tar.gz"))
+ (sha256
+ (base32 "1d023cphzi15k434n60l1rp5awxmdijvsxfrm59fmsvd5rjxh9q7"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("bmake" ,bmake)
+ ("pkg-config" ,pkg-config)
+ ("wayland-protocols" ,wayland-protocols)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("libinput" ,libinput)
+ ("libucl" ,libucl)
+ ("libxkbcommon" ,libxkbcommon)
+ ("pam" ,linux-pam)
+ ("pango" ,pango)
+ ("wayland" ,wayland)
+ ("wlroots" ,wlroots)))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target))
+ "WITH_XWAYLAND=YES"
+ "WITH_SCREENCOPY=YES"
+ "WITH_LAYERSHELL=YES"
+ "WITH_VIRTUAL_INPUT=YES")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key inputs outputs make-flags #:allow-other-keys)
+ (apply invoke "bmake" make-flags)))
+ (replace 'install
+ (lambda* (#:key inputs outputs make-flags #:allow-other-keys)
+ (apply invoke "bmake" "install" make-flags))))))
+ (home-page "https://hikari.acmelabs.space/")
+ (synopsis "Stacking Wayland compositor with tiling capabilities")
+ (description
+ "Hikari is a stacking Wayland compositor with additional tiling
+capabilities. It is heavily inspired by the Calm Window manager(cwm).")
+ (license license:bsd-2)))