aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-20 17:01:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-20 17:01:39 +0100
commit2c76e19df4b0b4aa0171f1edd9f240f7b6ba5b84 (patch)
treec2e7a7f27dd9c7e704f2e78655328c903a6934d1 /gnu/packages/wm.scm
parente6a668ec7303a71f87e4c9354b1458e555058c63 (diff)
parent78b2eb1ad3dcf05c25e0ee4980c97aa52de03a2d (diff)
downloadguix-2c76e19df4b0b4aa0171f1edd9f240f7b6ba5b84.tar.gz
guix-2c76e19df4b0b4aa0171f1edd9f240f7b6ba5b84.zip
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f1f3c25391..554a14154c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;;
@@ -190,17 +190,12 @@ commands would.")
"0xl56y196vxv001gvx35xwfr25zah8m3xwizp9ycdgdc0rfc4rdb"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list "CC=gcc"
- (string-append "PREFIX=" %output)
- ;; This works around the following error:
- ;; 'error: ‘for’ loop initial declarations are only allowed in C99
- ;; or C11 mode'
- "CFLAGS=-std=c11")
+ `(#:configure-flags
;; The build system tries to build in a separate directory, but that
;; seems to be unnecessary.
- #:configure-flags '("--disable-builddir")
- ;; The test suite appears to require the unpackaged Perl module AnyEvent.
+ (list "--disable-builddir")
+
+ ;; The test suite requires the unpackaged Xephyr X server.
#:tests? #f))
(inputs
`(("libxcb" ,libxcb)
@@ -228,10 +223,16 @@ commands would.")
("libxml2" ,libxml2)
("docbook-xsl" ,docbook-xsl)))
(home-page "https://i3wm.org/")
- (synopsis "Improved tiling window manager")
- (description "A tiling window manager, completely written
-from scratch. i3 is primarily targeted at advanced users and
-developers.")
+ (synopsis "Tiling window manager")
+ (description "i3 is a tiling X11 window manager that dynamically manages
+tiled, stacked, and tabbed window layouts.
+
+i3 primarily targets advanced users. Windows are managed manually and organised
+inside containers, which can be split vertically or horizontally, and optionally
+resized.
+
+i3 uses a plain-text configuration file, and can be extended and controlled from
+many programming languages.")
(license license:bsd-3)))
(define-public i3blocks