aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/webkit.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
guix-8394619baceb118df92e355377fd543bb1aa501a.zip
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index a1cffb55b3..65ad122f9c 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -86,9 +86,9 @@
`(("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
- `(("mesa" ,mesa)))
+ (list mesa))
(propagated-inputs
- `(("libxkbcommon" ,libxkbcommon)))
+ (list libxkbcommon))
(synopsis "General-purpose library for WPE")
(description "LibWPE is general-purpose library specifically developed for
the WPE-flavored port of WebKit.")
@@ -110,12 +110,9 @@ the WPE-flavored port of WebKit.")
(arguments
`(#:tests? #f)) ;no tests
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("glib" ,glib)
- ("libwpe" ,libwpe)
- ("mesa" ,mesa)
- ("wayland" ,wayland)))
+ (list glib libwpe mesa wayland))
(home-page "https://wpewebkit.org/")
(synopsis "Wayland WPE backend")
(description
@@ -317,8 +314,7 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
("docbook-xml" ,docbook-xml) ; For documentation generation
("ruby" ,ruby)))
(propagated-inputs
- `(("gtk+" ,gtk+)
- ("libsoup" ,libsoup)))
+ (list gtk+ libsoup))
(inputs
`(("at-spi2-core" ,at-spi2-core)
("bubblewrap" ,bubblewrap)
ellseher 2024-01-03gnu: go-github-com-google-safehtml: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-microcosm-cc-bluemonday: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-context: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-tdewolff-parse-v2: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-tdewolff-minify-v2: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-csrf: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-jcmturner-goidentity-v6: Adjust inputs....Sharlatan Hellseher 2024-01-03gnu: go-github-com-jcmturner-goidentity-v6: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-jcmturner-dnsutils-v2: Adjust inputs....Sharlatan Hellseher 2024-01-03gnu: go-github-com-jcmturner-dnsutils-v2: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-jcmturner-gokrb5-v8: Adjust inputs....Sharlatan Hellseher 2024-01-03gnu: go-github-com-jcmturner-gokrb5-v8: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-sessions: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-securecookie: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-felixge-httpsnoop: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-handlers: Remove input labels....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-handlers: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-sourcegraph-jsonrpc2: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-websocket: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-chris-ramon-douceur: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-puerkitobio-goquery: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-andybalholm-cascadia: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-aymerick-douceur: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-css: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: go-github-com-gorilla-mux: Move to (gnu packages golang-web)....Sharlatan Hellseher 2024-01-03gnu: Add (gnu packages golang-web) module....Sharlatan Hellseher