aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-02-27 11:53:06 -0500
committerMark H Weaver <mhw@netris.org>2015-02-28 09:49:01 -0500
commit722ec722441a755e18fbc696d23441427dfb26af (patch)
tree8d429f0ec1b30d692ab24bc07838e47b4cb33ab8 /gnu/packages/web.scm
parentdd0a8ef15f903422c6b020e7d793986427add927 (diff)
downloadguix-722ec722441a755e18fbc696d23441427dfb26af.tar.gz
guix-722ec722441a755e18fbc696d23441427dfb26af.zip
gnu: Move autoconf-style phases after the unpack phase.
* gnu/packages/audio.scm (soundtouch)[arguments]: Move 'bootstrap' after 'unpack'. Remove custom /usr/bin/file patching, which will now be handled by the 'patch-usr-bin-file' phase. * gnu/packages/emacs.scm (emacs-w3m)[arguments]: Rename 'pre-configure' phase to 'autoconf' and move it after 'unpack'. * gnu/packages/fontutils.scm (libuninameslist)[arguments]: Move 'bootstrap' phase after 'unpack'. * gnu/packages/libevent.scm (libuv)[arguments]: Move 'autogen' phase after 'unpack'. Run "sh autogen.sh" instead of "./autogen.sh". * gnu/packages/linux.scm (bridge-utils)[arguments]: Move 'bootstrap' phase after 'unpack'. * gnu/packages/mail.scm (libetpan)[arguments]: Move 'autogen' phase after 'unpack'. Run "sh autogen.sh" instead of "./autogen.sh". Setenv "NOCONFIGURE" before running autogen.sh. * gnu/packages/package-management.scm (guix-devel)[arguments]: Move 'bootstrap' phase after 'unpack'. Run "sh autogen.sh" instead of "./autogen.sh". * gnu/packages/rdf.scm (lrdf)[arguments]: Move 'autoreconf' phase after 'remove-out-of-tree-references' phase. * gnu/packages/tor.scm (privoxy)[arguments]: Move 'autoconf' phase after 'unpack'. * gnu/packages/web.scm (libpsl)[arguments]: Move 'bootstrap' phase after 'unpack'. Run "sh autogen.sh" instead of "./autogen.sh". Remove 'fix-autogen-shebang' phase.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5296c43c53..f0f974661b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;;
@@ -258,18 +258,11 @@ for efficient socket-like bidirectional reliable communication channels.")
("which" ,which)
("libtool" ,libtool)))
(arguments
- `(#:phases (alist-cons-before
- 'bootstrap 'fix-autogen-shebang
+ `(#:phases (alist-cons-after
+ 'unpack 'bootstrap
(lambda _
- (substitute* "autogen.sh"
- ;; Removing -e as it causes the whole script to fail when
- ;; `which gtkdocize` fails.
- (("# !/bin/sh -e") (string-append "#!" (which "sh")))))
- (alist-cons-before
- 'patch-usr-bin-file 'bootstrap
- (lambda _
- (zero? (system* "./autogen.sh")))
- %standard-phases))))
+ (zero? (system* "sh" "autogen.sh")))
+ %standard-phases)))
(home-page "https://github.com/rockdaboot/libpsl")
(synopsis "C library for the Publix Suffix List")
(description