aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-30 04:09:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-30 09:25:36 +0100
commit6d286d82046479661dcaf3add91912b216b6e358 (patch)
tree4c506e9603014bfa319531b1f5edd250cc7a6884 /gnu/packages/web.scm
parent581ae110de2f326fbfeb1c789ec1801997ea9566 (diff)
downloadguix-6d286d82046479661dcaf3add91912b216b6e358.tar.gz
guix-6d286d82046479661dcaf3add91912b216b6e358.zip
gnu: nginx, nginx-documentation: End phases with #t.
* gnu/packages/web.scm (nginx, nginx-documentation)[arguments]: End phases with #t. Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 08485cadb2..3a3311003f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -230,7 +230,8 @@ Interface} specification.")
(setenv "CC" "gcc")
(format #t "environment variable `CC' set to `gcc'~%")
(format #t "configure flags: ~s~%" flags)
- (zero? (apply system* "./configure" flags)))))
+ (apply invoke "./configure" flags)
+ #t)))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -251,7 +252,8 @@ Interface} specification.")
(rename-file (string-append out "/conf")
(string-append share "/conf"))
(rename-file (string-append out "/html")
- (string-append share "/html"))))))))
+ (string-append share "/html"))
+ #t))))))
(home-page "https://nginx.org")
(synopsis "HTTP and reverse proxy server")
(description
@@ -343,7 +345,8 @@ documentation.")
(("#banner \\{ background: black;")
"#banner { background: black;
display: none;"))
- (zero? (system* "make")))))
+ (invoke "make")
+ #t)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((output (assoc-ref outputs "out")))
>Merge branch 'master' into core-updatesMarius Bakke 2020-03-02file-systems: Add a 'file-system-device->string' procedure....Maxim Cournoyer 2020-02-11system: Stop using canonical-package....Mathieu Othacehe 2020-01-12system: Drop net-tools from %BASE-PACKAGES (replaced by iproute2)....Simon Josefsson 2020-01-08system: Use the udev-enabled util-linux variant....Marius Bakke 2019-12-07services: Add 'provenance-service-type'....Ludovic Courtès 2019-12-01system: vm: Support cross-compilation....Mathieu Othacehe 2019-10-06Merge branch 'master' into core-updatesRicardo Wurmus 2019-10-06system: Add 'mount' and 'umount' to '%setuid-programs'....Ludovic Courtès 2019-09-06Merge branch 'master' into core-updatesMark H Weaver 2019-08-30system: Add 'bootloader-menu-entries' field to <boot-parameters>....Ludovic Courtès 2019-07-16system: Write the timezone to /etc/timezone....Timothy Sample 2019-05-15system: Add 'operating-system-with-gc-roots'....Ludovic Courtès 2019-05-10system: Export 'operating-system-default-essential-services'....Ludovic Courtès 2019-04-27system: Add boot file systems to /etc/fstab....Ludovic Courtès 2019-04-25system: Add guile-readline and guile-colorized to %BASE-PACKAGES....Ludovic Courtès 2019-04-22system: Change default kernel-arguments to '("quiet")....Christopher Baines 2019-04-15system: Add 'label' field to <operating-system>....Ludovic Courtès 2019-04-14system: Remove "beta" from GRUB menu entries....Ludovic Courtès 2019-03-30system: Define 'this-operating-system'....Ludovic Courtès 2019-03-25system: Add 'essential-services' field to <operating-system>....Ludovic Courtès 2019-03-24system: Initialize console keyboard layout in the initrd....Ludovic Courtès 2019-03-22system: Fix misleading comments....Ludovic Courtès