aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-04-26 20:08:49 +0200
committerAndreas Enge <andreas@enge.fr>2015-04-26 20:08:49 +0200
commit4ac0d6444d4edf38edc7c07331cf76deb4a506bc (patch)
tree5264c9c87172b8f0015823b0ee891d3672ac291a /gnu/packages/web.scm
parentd074e2f99130782e8eb7fa44c79c01db6c86f77d (diff)
parent7bde30e18de3e8cd7e4156ea5bb0d9439b6c12d7 (diff)
downloadguix-4ac0d6444d4edf38edc7c07331cf76deb4a506bc.tar.gz
guix-4ac0d6444d4edf38edc7c07331cf76deb4a506bc.zip
Merge branch 'master' into core-updates.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0c22562aa6..fb3ff2d149 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -94,14 +94,14 @@ and its related documentation.")
(define-public nginx
(package
(name "nginx")
- (version "1.6.2")
+ (version "1.8.0")
(source (origin
(method url-fetch)
(uri (string-append "http://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "060s77qxhkn02fjkcndsr0xppj2bppjzkj0gn84svrykb4lqqq5m"))))
+ "1mgkkmmwkhmpn68sdvbd73ssv6lpqhh864fsyvc1ij4hk4is3k13"))))
(build-system gnu-build-system)
(inputs `(("pcre" ,pcre)
("openssl" ,openssl)
@@ -132,7 +132,12 @@ and its related documentation.")
(%current-system))
("x86_64-linux" "x86_64")
("i686-linux" "i686")
- ("mips64el-linux" "mips64"))))
+ ("mips64el-linux" "mips64")
+ ;; Prevent errors when querying
+ ;; this package on unsupported
+ ;; platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED"))))
(string-append "--crossbuild="
system ":" release ":" machine)))))
(setenv "CC" "gcc")