aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-17 15:15:38 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-19 16:43:31 -0500
commit040a52fd75bce0b45b36434ead1cdc393611bcb9 (patch)
tree719cc6ec5db586bfe76ee7dddef611275807564a /gnu/packages/web.scm
parent4306f28be5dae5313b4fbcfe69c78800476e068f (diff)
downloadguix-040a52fd75bce0b45b36434ead1cdc393611bcb9.tar.gz
guix-040a52fd75bce0b45b36434ead1cdc393611bcb9.zip
gnu: Add Catalyst-Component-InstancePerContext.
* gnu/packages/web.scm (perl-catalyst-component-instancepercontext): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f5d88a75b0..6950f5656a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -555,6 +555,30 @@ action with the generated name, and failing that it will try to dispatch to a
regular method.")
(license (package-license perl))))
+(define-public perl-catalyst-component-instancepercontext
+ (package
+ (name "perl-catalyst-component-instancepercontext")
+ (version "0.001001")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/G/GR/GRODITI/"
+ "Catalyst-Component-InstancePerContext-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0wfj4vnn2cvk6jh62amwlg050p37fcwdgrn9amcz24z6w4qgjqvz"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-catalyst-runtime" ,perl-catalyst-runtime)
+ ("perl-moose" ,perl-moose)))
+ (home-page
+ "http://search.cpan.org/dist/Catalyst-Component-InstancePerContext")
+ (synopsis "Create only one instance of Moose component per context")
+ (description "Catalyst::Component::InstancePerContext returns a new
+instance of a component on each request.")
+ (license (package-license perl))))
+
(define-public perl-catalyst-plugin-authentication
(package
(name "perl-catalyst-plugin-authentication")