aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-09 15:09:43 -0500
committerLeo Famulari <leo@famulari.name>2021-02-09 15:09:43 -0500
commit388bd35dd0df2d231bc2cce3746d7d5fd15df23a (patch)
tree82e7cc45b8279f83439214c7c79dc7161ffda94d /gnu/packages/web-browsers.scm
parentf1c7c2f697877fcb68b53ea062ff8a88f274a2fe (diff)
parentd00380b0077b0df2a0b790bb115d07c1533b8863 (diff)
downloadguix-388bd35dd0df2d231bc2cce3746d7d5fd15df23a.tar.gz
guix-388bd35dd0df2d231bc2cce3746d7d5fd15df23a.zip
Merge branch 'master' into staging-next
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 1040e79593..6fa56e7d99 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -586,6 +586,34 @@ vim editor and also easily configurable during runtime. Vimb is mostly keyboard
driven and does not detract you from your daily work.")
(license license:gpl3+)))
+;; Nyxt 2 pre-release 5 is incompatible with the new nickname "class*" of defclass-star.
+;; Use the older commit then.
+(define sbcl-hu.dwim.defclass-star--no-nickname
+ (let ((commit "2cf30b37006824ec912cf7732fe6c4f4b414597f"))
+ (package
+ (name "sbcl-hu.dwim.defclass-star")
+ ;; We used to set version from the date when it was a darcs repo, so we
+ ;; keep the year so that package gets updated on previous installs.
+ (version (git-version "2015-07-09" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hu-dwim/hu.dwim.defclass-star")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zmzvwgcp6lpkqxnfphd05v20xqsvz392mx1v98469kavh4zd7hf"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("hu.dwim.asdf" ,sbcl-hu.dwim.asdf)))
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://github.com/hu-dwim/hu.dwim.defclass-star")
+ (synopsis "See sbcl-hu.dwim.defclass-star")
+ (description "See sbcl-hu.dwim.defclass-star.")
+ (license license:public-domain))))
+
(define-public nyxt
(package
(name "nyxt")
@@ -672,7 +700,8 @@ driven and does not detract you from your daily work.")
("dexador" ,sbcl-dexador)
("enchant" ,sbcl-enchant)
("fset" ,sbcl-fset)
- ("hu.dwim.defclass-star" ,sbcl-hu.dwim.defclass-star)
+ ;; TODO: Use latest upstream for 2 pre-release 6 onward.
+ ("hu.dwim.defclass-star" ,sbcl-hu.dwim.defclass-star--no-nickname)
("iolib" ,sbcl-iolib)
("local-time" ,sbcl-local-time)
("log4cl" ,sbcl-log4cl)