aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAndré Batista <nandre@riseup.net>2024-09-03 11:30:59 -0300
committerLudovic Courtès <ludo@gnu.org>2024-09-04 19:17:01 +0200
commited95ddeb1e58c314f2e22b4cd35986042f3e2f21 (patch)
tree51f06d2508a6dc8f3d99554e2b17e9fdf432cfb4 /gnu/packages/video.scm
parent13e7bc4e0133a7ff4910d906d5382ce3038ea76d (diff)
downloadguix-ed95ddeb1e58c314f2e22b4cd35986042f3e2f21.tar.gz
guix-ed95ddeb1e58c314f2e22b4cd35986042f3e2f21.zip
gnu: ffmpeg-{5,4,3}: Fix build on i686 with binutils 2.41.
Fixes <https://issues.guix.gnu.org/72917>. * gnu/packages/video.scm (ffmpeg-5): Replace 'bypass-openal-check string substitution with one that matches on this and earlier versions of ffmpeg. (ffmpeg-4): Inherit package arguments from ffmpeg-5. Reported-by: Dariqq <dariqq@posteo.net> Change-Id: Ie5b51a174be45b511757dece369563975e498bac Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 830883e110..9e4b246241 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1845,6 +1845,9 @@ operate properly.")
;; https://lists.gnu.org/archive/html/guix-devel/2024-08/msg00159.html
(lambda _
(substitute* "configure"
+ ;; This string only matches on ffmpeg v6 and above.
+ ;; Replace it with the one defined at ffmpeg-5 which
+ ;; matches on all ffmpeg versions. See #71917.
(("alGetError \\|\\|")
"alGetError \|\| true \|\|")))))
#~())
@@ -1889,7 +1892,18 @@ audio/video codec library.")
version ".tar.xz"))
(sha256
(base32
- "0qwhyhil805hns7yksdxagnrcc90h60al7lz1rc65kd1j2w3nf2l"))))))
+ "0qwhyhil805hns7yksdxagnrcc90h60al7lz1rc65kd1j2w3nf2l"))))
+ (arguments
+ (if (target-x86-32?)
+ (substitute-keyword-arguments (package-arguments ffmpeg)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'bypass-openal-check
+ (lambda _
+ (substitute* "configure"
+ (("die \"ERROR: openal not found\"")
+ "true")))))))
+ (package-arguments ffmpeg)))))
(define-public ffmpeg-4
(package
@@ -1907,7 +1921,7 @@ audio/video codec library.")
(inputs (modify-inputs (package-inputs ffmpeg)
(replace "sdl2" sdl2-2.0)))
(arguments
- (substitute-keyword-arguments (package-arguments ffmpeg)
+ (substitute-keyword-arguments (package-arguments ffmpeg-5)
((#:configure-flags flags ''())
#~(cons "--enable-avresample" #$flags))))))