aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:38 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:35 +0200
commitc209f4db0a201b8512763da69961d95eb88697b5 (patch)
tree3d7bc0e61690b3fb22256630682d6c83e2e7094f /gnu/packages/video.scm
parent94e76840040b34f12fb8093cec14b1d777bcf215 (diff)
downloadguix-c209f4db0a201b8512763da69961d95eb88697b5.tar.gz
guix-c209f4db0a201b8512763da69961d95eb88697b5.zip
gnu: video: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/video.scm (pipe-viewer)[inputs]: Add 'bash-minimal'. (vlc): Remove trailing #t. (youtube-viewer)[inputs]: Likewise. (openshot)[inputs]: Likewise. (gaupol)[inputs]: Likewise. (get-iplayer)[inputs]: Likewise. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I572eddc1084e1397b06d1fa264ec575c8c9b5340
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6ee151d656..a10448fde9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1260,7 +1260,8 @@ H.264 (MPEG-4 AVC) video streams.")
(native-inputs
(list perl-module-build perl-test-pod perl-test-simple))
(inputs
- (list perl-data-dump
+ (list bash-minimal
+ perl-data-dump
perl-digest-md5
perl-encode
ffmpeg
@@ -2483,8 +2484,7 @@ input files is possible, including video files.")
;; Some of the tests require using the display to test out VLC,
;; which fails in our sandboxed build system
(substitute* "test/run_vlc.sh"
- (("./vlc --ignore-config") "echo"))
- #t)))
+ (("./vlc --ignore-config") "echo")))))
(add-after 'strip 'regenerate-plugin-cache
(lambda* (#:key outputs #:allow-other-keys)
;; The 'install-exec-hook' rule in the top-level Makefile.am
@@ -2510,8 +2510,7 @@ input files is possible, including video files.")
(let ((out (assoc-ref outputs "out"))
(plugin-path (getenv "QT_PLUGIN_PATH")))
(wrap-program (string-append out "/bin/vlc")
- `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
- #t)))))
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
(home-page "https://www.videolan.org/")
(synopsis "Audio and video framework")
(description "VLC is a cross-platform multimedia player and framework
@@ -3250,7 +3249,8 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(native-inputs
(list perl-module-build))
(inputs
- (list perl-data-dump
+ (list bash-minimal
+ perl-data-dump
perl-file-sharedir
perl-gtk2
perl-json
@@ -3284,8 +3284,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
"bin/gtk3-youtube-viewer")
(("'xdg-open'")
(format #f "'~a/bin/xdg-open'"
- (assoc-ref inputs "xdg-utils"))))
- #t))
+ (assoc-ref inputs "xdg-utils"))))))
(add-after 'install 'install-desktop
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -3293,8 +3292,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(install-file "share/gtk-youtube-viewer.desktop"
(string-append sharedir "/applications"))
(install-file "share/icons/gtk-youtube-viewer.png"
- (string-append sharedir "/pixmaps"))
- #t)))
+ (string-append sharedir "/pixmaps")))))
(add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -3303,8 +3301,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(lib-path (getenv "PERL5LIB")))
(for-each (cut wrap-program <>
`("PERL5LIB" ":" prefix (,lib-path ,site-dir)))
- (find-files bin-dir))
- #t))))))
+ (find-files bin-dir))))))))
(synopsis
"Lightweight application for searching and streaming videos from YouTube")
(description
@@ -5895,7 +5892,8 @@ API. It includes bindings for Python, Ruby, and other languages.")
(delete-file-recursively "src/images/fonts") #t))))
(build-system python-build-system)
(inputs
- (list ffmpeg
+ (list bash-minimal
+ ffmpeg
font-dejavu
libopenshot
python
@@ -5924,14 +5922,12 @@ API. It includes bindings for Python, Ruby, and other languages.")
(substitute* "src/classes/app.py"
(("info.IMAGES_PATH") (string-append "\"" font "\""))
(("fonts") "share/fonts/truetype")
- (("[A-Za-z_-]+.ttf") "DejaVuSans.ttf")))
- #t))
+ (("[A-Za-z_-]+.ttf") "DejaVuSans.ttf")))))
(add-before 'install 'set-tmp-home
(lambda _
;; src/classes/info.py "needs" to create several
;; directories in $HOME when loaded during build
- (setenv "HOME" "/tmp")
- #t))
+ (setenv "HOME" "/tmp")))
(add-after 'install 'wrap-program
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -6086,7 +6082,8 @@ video from a Wayland session.")
(native-inputs
(list gettext-minimal pkg-config))
(inputs
- (list python-pygobject
+ (list bash-minimal
+ python-pygobject
gtk+
python-pycairo ; Required or else clicking on a subtitle line fails.
python-chardet ; Optional: Character encoding detection.
@@ -6537,7 +6534,10 @@ brightness, contrast, and frame rate.")
`("PERL5LIB" ":"
prefix (,(string-append perllib ":" (getenv "PERL5LIB")))))))))))
(inputs
- (list perl-mojolicious perl-lwp-protocol-https perl-xml-libxml))
+ (list bash-minimal
+ perl-mojolicious
+ perl-lwp-protocol-https
+ perl-xml-libxml))
(home-page "https://github.com/get-iplayer/get_iplayer")
(synopsis "Download or stream available BBC iPlayer TV and radio programmes")
(description "@code{get_iplayer} lists, searches and records BBC iPlayer