aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2024-10-13 12:00:55 -0700
committerLudovic Courtès <ludo@gnu.org>2024-10-15 18:40:09 +0200
commitb59632da27aec2e4333df647ff76f9830f97f431 (patch)
tree487e7d5cb1ecd62ceb6a99f87df4110ecfb8312b /gnu/packages/video.scm
parentd268c964af758d83135f82489846210fe7bd8491 (diff)
downloadguix-b59632da27aec2e4333df647ff76f9830f97f431.tar.gz
guix-b59632da27aec2e4333df647ff76f9830f97f431.zip
gnu: jellyfin-mpv-shim: Fix icon & metainfo installation.
The icons and appdata.xml were getting installed into share/applications, when they should have gone into share/icons/hicolor and share/metainfo. Put them in the right place, which allows DEs to find them. * gnu/packages/video.scm (jellyfin-mpv-shim): In 'install-desktop-file phase, change the icon and metadata file name. Change-Id: Ic6cdae2fe0b348b94285bf8b39c014922baae6c1 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1d2ab5fbeb..92c0acef3c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2830,16 +2830,24 @@ the last played position, etc.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(apps (string-append out "/share/applications"))
+ (metainfo (string-append out "/share/metainfo"))
+ (icons (string-append out "/share/icons"))
(desktop-base "jellyfin_mpv_shim/integration/")
(package-id
"com.github.iwalton3.jellyfin-mpv-shim"))
(for-each (lambda (size)
- (install-file (format #f
- "~ajellyfin-~a.png"
- desktop-base size) apps))
+ (let ((dir (format
+ #f "~a/hicolor/~ax~a/apps/"
+ icons size size package-id)))
+ (mkdir-p dir)
+ (copy-file
+ (format #f
+ "~ajellyfin-~a.png"
+ desktop-base size)
+ (string-append dir package-id ".png"))))
'(256 128 64 48 32 16))
(install-file (string-append desktop-base package-id
- ".appdata.xml") apps)
+ ".appdata.xml") metainfo)
(install-file (string-append desktop-base package-id
".desktop") apps)))))))
(inputs (list `(,python "tk")