aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:08 +0200
commit96727475fb295c0b2b0c68bf6a05f9ff5829f86c (patch)
tree33ff126b8503109ec4f0db0402db15c6ab1173db /gnu/packages/video.scm
parentc89173cf466046c830bc0cf99a149996d6e21b14 (diff)
downloadguix-96727475fb295c0b2b0c68bf6a05f9ff5829f86c.tar.gz
guix-96727475fb295c0b2b0c68bf6a05f9ff5829f86c.zip
gnu: mplayer: Use G-expressions.
* gnu/packages/video.scm (mplayer)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm74
1 files changed, 37 insertions, 37 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index df93576525..eb60e71d7b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2109,6 +2109,43 @@ streaming protocols.")
(base32
"11dzrdb74ayvivcid3giqncrfm98hi4aqvg3kjrwji6bnddxa335"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no test target
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ ;; configure does not work followed by "SHELL=..." and
+ ;; "CONFIG_SHELL=..."; set environment variables instead
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "configure"
+ (("#! /bin/sh") (string-append "#!" (which "sh"))))
+ (setenv "SHELL" (which "bash"))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (invoke "./configure"
+ (string-append "--extra-cflags=-I"
+ #$(this-package-input "libx11")
+ "/include") ; to detect libx11
+ "--disable-ffmpeg_a" ; disables bundled ffmpeg
+ (string-append "--prefix=" #$output)
+ ;; Enable runtime cpu detection where supported,
+ ;; and choose a suitable target.
+ #$@(match (or (%current-target-system)
+ (%current-system))
+ ("x86_64-linux"
+ '("--enable-runtime-cpudetection"
+ "--target=x86_64-linux"))
+ ("i686-linux"
+ '("--enable-runtime-cpudetection"
+ "--target=i686-linux"))
+ ("mips64el-linux"
+ '("--target=mips3-linux"))
+ (_ (list (string-append
+ "--target="
+ (or (%current-target-system)
+ (nix-system->gnu-triplet
+ (%current-system)))))))
+ "--disable-iwmmxt"))))))
;; FIXME: Add additional inputs once available.
(native-inputs
(list pkg-config yasm))
@@ -2144,43 +2181,6 @@ streaming protocols.")
sdl
speex
zlib))
- (arguments
- `(#:tests? #f ; no test target
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- ;; configure does not work followed by "SHELL=..." and
- ;; "CONFIG_SHELL=..."; set environment variables instead
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (libx11 (assoc-ref inputs "libx11")))
- (substitute* "configure"
- (("#! /bin/sh") (string-append "#!" (which "sh"))))
- (setenv "SHELL" (which "bash"))
- (setenv "CONFIG_SHELL" (which "bash"))
- (invoke "./configure"
- (string-append "--extra-cflags=-I"
- libx11 "/include") ; to detect libx11
- "--disable-ffmpeg_a" ; disables bundled ffmpeg
- (string-append "--prefix=" out)
- ;; Enable runtime cpu detection where supported,
- ;; and choose a suitable target.
- ,@(match (or (%current-target-system)
- (%current-system))
- ("x86_64-linux"
- '("--enable-runtime-cpudetection"
- "--target=x86_64-linux"))
- ("i686-linux"
- '("--enable-runtime-cpudetection"
- "--target=i686-linux"))
- ("mips64el-linux"
- '("--target=mips3-linux"))
- (_ (list (string-append
- "--target="
- (or (%current-target-system)
- (nix-system->gnu-triplet
- (%current-system)))))))
- "--disable-iwmmxt")))))))
(home-page "https://www.mplayerhq.hu")
(synopsis "Audio and video player")
(description "MPlayer is a movie player. It plays most MPEG/VOB, AVI,