aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2024-07-13 17:59:34 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-15 21:37:00 +0800
commit8c86eaeac6a20edad6c3c938df3815a6bcb86270 (patch)
tree60993e500fb44e9d2fc8b57452e7544fc0b6ee33 /gnu/packages/video.scm
parent1cd1caceedb55ed9f7071ca3f0a15930f563f9c2 (diff)
downloadguix-8c86eaeac6a20edad6c3c938df3815a6bcb86270.tar.gz
guix-8c86eaeac6a20edad6c3c938df3815a6bcb86270.zip
gnu: smplayer: Update to 22.2.0.
* gnu/packages/video.scm (smplayer) [origin]: Build from the git repo. [arguments]: Remove LRELEASE kludge. Change-Id: Iff065784a2b2ef677807e4194ca04ce2ec501fef Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm29
1 files changed, 8 insertions, 21 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b6bf9236b2..de518ab46a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2711,15 +2711,15 @@ projects while introducing many more.")
(define-public smplayer
(package
(name "smplayer")
- (version "21.10.0")
+ (version "22.2.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://sourceforge/smplayer/SMPlayer/" version
- "/smplayer-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smplayer-dev/smplayer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "12nvcl0cfix1xay9hfi7856vg4lpv8y5b0a22212bsjbvl5g22rc"))))
+ (base32 "0mcvpm86n9l0nwavnaa1n2jfalgrzdfh92sdjnwx1iga89m4k55s"))))
(build-system qt-build-system)
(native-inputs
(list qttools-5))
@@ -2728,23 +2728,10 @@ projects while introducing many more.")
(arguments
(list #:tests? #false ; no tests
#:make-flags #~(list (string-append "PREFIX=" #$output)
- (string-append "CC=" #+(cc-for-target))
- ;; A KLUDGE to turn off invoking lrelease on the
- ;; project for now, because it fails consistently
- ;; with "WARNING: Could not find qmake spec
- ;; 'default'". See below.
- "LRELEASE=true")
+ (string-append "CC=" #+(cc-for-target)))
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
- ;; Due to the above, we must run lrelease separately on each .ts file
- ;; (as opposed to running `lrelease-pro smplayer.pro` for the entire
- ;; project, as the Makefile does normally without the above kludge).
- (add-after 'build 'compile-ts-files
- (lambda _
- (for-each (lambda (file)
- (invoke "lrelease" file))
- (find-files "./" "\\.ts$"))))
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))