aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-19 15:11:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:27 +0200
commit7fdf181e36875bae8bb43a6bc2ed05f91f42c96b (patch)
tree37f7d170702e1770409a59fe614422cbe942c6e0 /gnu/packages/video.scm
parentc2e6bc41f148f44a8f24d68cdc68b9dc37a5159c (diff)
downloadguix-7fdf181e36875bae8bb43a6bc2ed05f91f42c96b.tar.gz
guix-7fdf181e36875bae8bb43a6bc2ed05f91f42c96b.zip
gnu: ffmpeg: Build with rav1e on more systems.
* gnu/packages/video.scm (ffmpeg)[inputs]: Add rav1e on all systems where it is supported. [arguments]: Add flag to use rav1e when it is added as an input. Change-Id: I53cc11cd406b165dc366ebe547ae6574ea9f58a3
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7df4b427ed..9b6910cc88 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1681,9 +1681,7 @@ operate properly.")
(build-system gnu-build-system)
(inputs
(append
- ;; XXX: rav1e depends on rust, which currently only works on x86_64.
- ;; See also the related configure flag when changing this.
- (if (target-x86-64?) (list rav1e) '())
+ (if (supported-package? rav1e) (list rav1e) '())
(list dav1d
fontconfig
freetype
@@ -1796,7 +1794,7 @@ operate properly.")
"--enable-libmp3lame"
"--enable-libopus"
"--enable-libpulse"
- #$@(if (target-x86-64?)
+ #$@(if (this-package-input "rav1e")
'("--enable-librav1e")
'())
"--enable-libsoxr"