aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-21 23:09:11 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-27 19:39:31 +0100
commit6f6c8b653792599f2e866887b29c86dd51638d15 (patch)
tree3b10c077c3c8fe9bd6a1386cc2929f064d4acc5c /gnu/packages/video.scm
parentd814be32d5205fc946ba4dce724b6202718df268 (diff)
downloadguix-6f6c8b653792599f2e866887b29c86dd51638d15.tar.gz
guix-6f6c8b653792599f2e866887b29c86dd51638d15.zip
gnu: Add vapoursynth.
* gnu/packages/video.scm (vapoursynth): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cca26f1840..c202c6f140 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages mp3)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages ocr)
#:use-module (gnu packages openssl)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -1095,6 +1096,47 @@ capabilities.")
(alist-delete 'install
%standard-phases)))))))))
+(define-public vapoursynth
+ (package
+ (name "vapoursynth")
+ (version "26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/vapoursynth/vapoursynth/archive/R"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1qbg5kg0kgrxldd0ckn1s7vy7vx2ig8nqzv6djp38fxccpzw3x9k"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("cython" ,python-cython)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)
+ ("yasm" ,yasm)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("libass" ,libass)
+ ("tesseract-ocr" ,tesseract-ocr)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ unpack autogen
+ (lambda _
+ (zero? (system* "sh" "autogen.sh")))))))
+ (home-page "http://www.vapoursynth.com/")
+ (synopsis "Video processing framework")
+ (description "VapourSynth is a C++ library and Python module for video
+manipulation. It aims to be a modern rewrite of Avisynth, supporting
+multithreading, generalized colorspaces, per frame properties, and videos with
+format changes.")
+ ;; As seen from the source files.
+ (license lgpl2.1+)))
+
(define-public xvid
(package
(name "xvid")