aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/video.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
downloadguix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.tar.gz
guix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.zip
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 000e0ecb44..77fd9999aa 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2365,6 +2365,7 @@ videoformats depend on the configuration flags of ffmpeg.")
`("PATH" ":" prefix
(,(search-input-file inputs ffm))))))))))
(inputs (list bash-minimal ffmpeg))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/slhck/ffmpeg-progress-yield")
(synopsis "Run an ffmpeg command with progress")
(description "This package allows an ffmpeg command to run with progress.
@@ -2398,7 +2399,7 @@ It is usually a complement to @code{ffmpeg-normalize}.")
(ffm (search-input-file inputs "bin/ffmpeg")))
(wrap-program ffn
`("FFMPEG_PATH" = (,ffm)))))))))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(inputs (list bash-minimal ffmpeg))
(propagated-inputs (list ffmpeg-progress-yield
python-colorama