aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2024-06-13 14:58:09 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2024-08-04 12:39:09 +0300
commit4aad2ff47cdbb02688c45a040405d3dca048834c (patch)
tree141697407cde87ee26ccfef5cac16061919790ca /gnu/packages/video.scm
parent5e355dd413f914bfc38e03fcfcbc4b421674c992 (diff)
downloadguix-4aad2ff47cdbb02688c45a040405d3dca048834c.tar.gz
guix-4aad2ff47cdbb02688c45a040405d3dca048834c.zip
gnu: Add obs-source-copy.
* gnu/packages/video.scm (obs-source-copy): New variable. Change-Id: I73fabb7061abcdad98a93f8ad7cab6ee1892ad9d
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ddfa3a2b72..089dd17201 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4162,6 +4162,35 @@ your host privately.")
inputs and applications using PipeWire.")
(license license:gpl2+)))
+(define-public obs-source-copy
+ (package
+ (name "obs-source-copy")
+ (version "0.2.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/exeldro/obs-source-copy")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l3ls3j57yh03vkwiah6yj1xnnmq7q2ngjjn1k4h1sqqk0dxn86j"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:configure-flags
+ #~(list (string-append "-DLIBOBS_INCLUDE_DIR="
+ #$(this-package-input "obs") "/lib")
+ "-DBUILD_OUT_OF_TREE=On"
+ "-Wno-dev")))
+ (inputs (list obs qtbase-5))
+ (home-page "https://github.com/exeldro/obs-source-copy")
+ (synopsis "OBS plugin for copy and paste scenes, sources and filters")
+ (description "This package provides an OBS plugin for copy and paste
+scenes, sources and filters.")
+ (license license:gpl2)))
+
(define-public obs-source-record
(package
(name "obs-source-record")