aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorJakob Kirsch <jakob.kirsch@web.de>2024-11-01 21:41:48 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 20:24:50 +0000
commit47b792658ee232b6d59a14fcf43d0309cb0d5000 (patch)
treed2ac0c136559cde5ed9a8f8d12f5d1a6b100c720 /gnu/packages/video.scm
parent3983f4da9448bff64b1d488497e163137776b2d0 (diff)
downloadguix-47b792658ee232b6d59a14fcf43d0309cb0d5000.tar.gz
guix-47b792658ee232b6d59a14fcf43d0309cb0d5000.zip
gnu: yt-dlp: Update to 2024.10.22.
* gnu/packages/video.scm (yt-dlp): Update to 2024.10.22. Change-Id: Ifd83fd76ffdb2d2ddab0c9577278a308a3f03cb5 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1fd0efbf90..9e59b20dbc 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3169,7 +3169,7 @@ YouTube.com and many more sites.")
(define-public yt-dlp
(package
(name "yt-dlp")
- (version "2024.08.06")
+ (version "2024.10.22")
(source
(origin
(method git-fetch)
@@ -3177,8 +3177,11 @@ YouTube.com and many more sites.")
(url "https://github.com/yt-dlp/yt-dlp/")
(commit version)))
(file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet '(substitute* "pyproject.toml"
+ (("^.*Programming Language :: Python :: 3\\.13.*$") "")))
(sha256
- (base32 "0k44p1a9nckj7m6gxz7zggci0iihflivxvkh9l8wwbnsfvqhyfrn"))))
+ (base32 "1gw19f4h71vlchljg08g5l8sd60gmflbdpxz2vsinxzkmqvrqnra"))))
(build-system pyproject-build-system)
(arguments
`(#:tests? ,(not (%current-target-system))