aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-08 08:37:30 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:33:13 +0100
commited1ef9bbb25c543dae8e2e9a90004755278839f4 (patch)
tree57b790025eb9ba64c6f24ba5a50b59200aa428b0 /gnu/packages/version-control.scm
parenta56e8f0a877b792f0da114e4fbc3fcee9598e11a (diff)
downloadguix-ed1ef9bbb25c543dae8e2e9a90004755278839f4.tar.gz
guix-ed1ef9bbb25c543dae8e2e9a90004755278839f4.zip
gnu: git-minimal: Support [cross-]build with gcc-14 and the 64bit Hurd.
* gnu/packages/version-control.scm (git-minimal)[arguments]: When building for the 64bit Hurd, or cross-compiling, use "-Wno-implicit-function-declaration" in #:make-flags. Use target-hurd? instead of comparing with "i586-pc-gnu" in "use-host-uname_S" phase. Change-Id: Ib9836be8a1e389a82c8a89adf22aaeac0d85bd14
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b352c8c65c..289b981911 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -296,7 +296,10 @@ Python 3.3 and later, rather than on Python 2.")
;; By default 'make install' creates hard links for
;; things in 'libexec/git-core', which leads to huge
;; nars; see <https://bugs.gnu.org/21949>.
- "NO_INSTALL_HARDLINKS=indeed")
+ "NO_INSTALL_HARDLINKS=indeed"
+ #$@(if (or (target-hurd64?) (%current-target-system))
+ #~("-Wno-implicit-function-declaration")
+ #~()))
#:phases
#~(modify-phases %standard-phases
#$@(if (%current-target-system)
@@ -305,7 +308,7 @@ Python 3.3 and later, rather than on Python 2.")
(lambda _
(substitute* "config.mak.uname"
(("uname_S := .*" all)
- (if (equal? #$(%current-target-system) "i586-pc-gnu")
+ (if #$(target-hurd?)
"uname_S := GNU\n"
all))))))
;; We do not have a full bash when cross-compiling.