aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-07-19 14:37:32 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-19 12:30:26 +0200
commitd3832de763777759eb1f56e20731cb39da4c7b5b (patch)
tree85aa8b6b84693de1d890910b55a69af6fb01b805 /gnu/packages/version-control.scm
parent07adb7e26a447361d474163dd8e1aeb5c36369e5 (diff)
downloadguix-d3832de763777759eb1f56e20731cb39da4c7b5b.tar.gz
guix-d3832de763777759eb1f56e20731cb39da4c7b5b.zip
gnu: libgit2-1.8: Update to 1.8.1.
* gnu/packages/version-control.scm (libgit2-1.8): Update to 1.8.1. [source]: deps/http-parser does not exist so update the list [arguments]: semantics of -DUSE_HTTP_PARSER has changed, so update configure-flags to reflect the same Change-Id: Ifd9694a93326f7c3d368bd354a5fadf4e4b93119 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a295974d4e..dae8770a27 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1025,7 +1025,7 @@ write native speed custom Git applications in any language with bindings.")
(define-public libgit2-1.8
(package
(inherit libgit2-1.7)
- (version "1.8.0")
+ (version "1.8.1")
(source (origin
(inherit (package-source libgit2-1.7))
(uri (git-reference
@@ -1034,7 +1034,23 @@ write native speed custom Git applications in any language with bindings.")
(file-name (git-file-name "libgit2" version))
(sha256
(base32
- "0f0vqml6fp94z07xkpim2sdj2xvpxnsrwbm1q1dibx4vqjd7mh3q"))))))
+ "1mh55804cvxl2cyl4clinajzgfn3zmlhacnv1pdvdj4w6z2w4si7"))
+ (snippet
+ '(begin
+ (for-each delete-file-recursively
+ '("deps/chromium-zlib"
+ "deps/llhttp"
+ "deps/ntlmclient"
+ "deps/pcre"
+ "deps/winhttp"
+ "deps/zlib"))))))
+ (arguments (substitute-keyword-arguments (package-arguments libgit2-1.7)
+ ((#:configure-flags flags #~(list))
+ #~(map (lambda (arg)
+ (if (string= "-DUSE_HTTP_PARSER=system" arg)
+ "-DUSE_HTTP_PARSER=http-parser"
+ arg))
+ #$flags))))))
(define-public libgit2-1.6
(package