aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorAndré Batista <nandre@riseup.net>2023-02-17 16:07:10 -0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-17 15:22:53 -0500
commit8d8e1438ae5a2e50005b500dacd0a26be540fe69 (patch)
tree5f59a39deacfc6b640149360ffe8bbab70d8a563 /gnu/packages/version-control.scm
parent7b4b2713786d7d29b0435fa3e4557d898ad95cb5 (diff)
downloadguix-8d8e1438ae5a2e50005b500dacd0a26be540fe69.tar.gz
guix-8d8e1438ae5a2e50005b500dacd0a26be540fe69.zip
gnu: libgit2: Update to 1.5.1 [security fixes].
Fixes CVE-2023-22742. Follows up on fixes to CVE-2022-24765. Provides compatibility with git changes to address CVE-2022-29187. * gnu/packages/version-control.scm (libgit2): Update to 1.5.1. [source]: Remove snippet to comment out the "10 years ago" test, which was removed on newer versions. (libgit2-1.4): New variable. Update to 1.4.5. (libgit2-1.3): Inherit from 'libgit2-1.4'. Update to 1.3.2. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm34
1 files changed, 21 insertions, 13 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index e72c560928..49dc96d454 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -804,7 +804,7 @@ to GitHub contributions calendar.")
(define-public libgit2
(package
(name "libgit2")
- (version "1.4.3")
+ (version "1.5.1")
(source (origin
;; Since v1.1.1, release artifacts are no longer offered (see:
;; https://github.com/libgit2/libgit2/discussions/5932#discussioncomment-1682729).
@@ -815,18 +815,11 @@ to GitHub contributions calendar.")
(file-name (git-file-name name version))
(sha256
(base32
- "02x1a4zrzpzjd0yxnsi8njh5hgihc1iy1v4r0fnl8m4ckcgp6x2s"))
+ "04ypzpicpgq1wh6anwcmjjyh2b854lvjhxq0hq2hbsx7kb14qc1b"))
(modules '((guix build utils)))
(snippet
'(begin
- (delete-file-recursively "deps")
-
- ;; The "refs:revparse::date" test is time-dependent: it
- ;; assumes "HEAD@{10 years ago}" matches a specific commit.
- ;; See <https://github.com/libgit2/libgit2/pull/6299>.
- (substitute* "tests/refs/revparse.c"
- (("test_object.*10 years ago.*" all)
- (string-append "// " all "\n")))))))
+ (delete-file-recursively "deps")))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
@@ -868,10 +861,10 @@ write native speed custom Git applications in any language with bindings.")
;; GPLv2 with linking exception
(license license:gpl2)))
-(define-public libgit2-1.3
+(define-public libgit2-1.4
(package
(inherit libgit2)
- (version "1.3.0")
+ (version "1.4.5")
(source (origin
(inherit (package-source libgit2))
(method git-fetch)
@@ -881,7 +874,22 @@ write native speed custom Git applications in any language with bindings.")
(file-name (git-file-name "libgit2" version))
(sha256
(base32
- "0vgpb2175a5dhqiy1iwywwppahgqhi340i8bsvafjpvkw284vazd"))))
+ "0q754ipc6skagszi93lcy6qr09ibavivm2q5i5fhpdblvlnv2p7x"))))))
+
+(define-public libgit2-1.3
+ (package
+ (inherit libgit2-1.4)
+ (version "1.3.2")
+ (source (origin
+ (inherit (package-source libgit2-1.4))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libgit2/libgit2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "libgit2" version))
+ (sha256
+ (base32
+ "1dngga8jq419z6ps65wpmh2jihcf70k6r98pb1m1yiwj7qqh9792"))))
(arguments
(substitute-keyword-arguments (package-arguments libgit2)
((#:phases _ '%standard-phases)