aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-11-17 21:22:16 -0600
committerEric Bavier <bavier@member.fsf.org>2014-12-02 08:33:30 -0600
commit7639105b1270dd8063c97e822276104595207211 (patch)
tree991f4f1c93949162968a5ebb8590123bed6c1792 /gnu/packages/version-control.scm
parentde878f1b296ec585c86fc041fce9d619e47c231f (diff)
downloadguix-7639105b1270dd8063c97e822276104595207211.tar.gz
guix-7639105b1270dd8063c97e822276104595207211.zip
gnu: subversion: Fix libtool wrapper execution in hooks.
* gnu/packages/version-control.scm (subversion)[arguments]: New 'patch-libtool-wrapper-ls phase.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm52
1 files changed, 32 insertions, 20 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8ee624f909..f5e9a27736 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -427,33 +427,45 @@ property manipulation.")
(version "1.7.18")
(source (origin
(method url-fetch)
- (uri (string-append "http://archive.apache.org/dist/subversion/subversion-"
- version ".tar.bz2"))
+ (uri (string-append "http://archive.apache.org/dist/subversion/"
+ "subversion-" version ".tar.bz2"))
(sha256
(base32
"06nrqnn3qq1hhskkcdbm0ilk2xv6ay2gyf2c7qvxp6xncb782wzn"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after
- 'install 'instal-perl-bindings
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Follow the instructions from
- ;; 'subversion/bindings/swig/INSTALL'.
- (let ((out (assoc-ref outputs "out")))
- (and (zero? (system* "make" "swig-pl-lib"))
- ;; FIXME: Test failures.
- ;; (zero? (system* "make" "check-swig-pl"))
- (zero? (system* "make" "install-swig-pl-lib"))
+ 'configure 'patch-libtool-wrapper-ls
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; This substitution allows tests svnauthz_tests and
+ ;; svnlook_tests to pass. These tests execute svnauthz and
+ ;; svnlook through their libtool wrapper scripts from svn
+ ;; hooks, whose empty environments cause "ls: command not
+ ;; found" errors. It would be nice if this fix ultimately
+ ;; made its way into libtool.
+ (let ((coreutils (assoc-ref inputs "coreutils")))
+ (substitute* "libtool"
+ (("\\\\`ls") (string-append "\\`" coreutils "/bin/ls")))))
+ (alist-cons-after
+ 'install 'instal-perl-bindings
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Follow the instructions from
+ ;; 'subversion/bindings/swig/INSTALL'.
+ (let ((out (assoc-ref outputs "out")))
+ (and (zero? (system* "make" "swig-pl-lib"))
+ ;; FIXME: Test failures.
+ ;; (zero? (system* "make" "check-swig-pl"))
+ (zero? (system* "make" "install-swig-pl-lib"))
- ;; Set the right installation prefix.
- (with-directory-excursion
- "subversion/bindings/swig/perl/native"
- (and (zero?
- (system* "perl" "Makefile.PL"
- (string-append "PREFIX=" out)))
- (zero?
- (system* "make" "install")))))))
- %standard-phases)))
+ ;; Set the right installation prefix.
+ (with-directory-excursion
+ "subversion/bindings/swig/perl/native"
+ (and (zero?
+ (system* "perl" "Makefile.PL"
+ (string-append "PREFIX=" out)))
+ (zero?
+ (system* "make" "install")))))))
+ %standard-phases))))
(native-inputs
`(("pkg-config" ,pkg-config)
;; For the Perl bindings.