aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:25 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:15 -0400
commit6a168919d28f34bc7f4f15f0ce30d7e464a8b363 (patch)
tree38762e5b6800f9adb3975751a63acc91594130dc /gnu/packages/version-control.scm
parenta8797329f9e663660383fab6c404c8fec6fbed28 (diff)
downloadguix-6a168919d28f34bc7f4f15f0ce30d7e464a8b363.tar.gz
guix-6a168919d28f34bc7f4f15f0ce30d7e464a8b363.zip
gnu: Add go-github-com-git-lfs-gitobj-v2.
* gnu/packages/version-control.scm (go-github-com-git-lfs-gitobj-v2): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 302f7c90ad..ffa1d1e3e4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2940,6 +2940,36 @@ the smallest possible conflicts and to allow a merge to be saved, tested,
interrupted, published, and collaborated on while in progress.")
(license license:gpl2+)))
+(define-public go-github-com-git-lfs-gitobj-v2
+ (package
+ (name "go-github-com-git-lfs-gitobj-v2")
+ (version "2.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/git-lfs/gitobj")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sd7y4xbx00js1g2az4nq8g5lvsm4d7nqr3v4kxy8fxrfzdm63j9"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/git-lfs/gitobj/v2"))
+ (propagated-inputs (list go-github-com-stretchr-testify
+ go-github-com-pmezard-go-difflib
+ go-github-com-davecgh-go-spew))
+ (home-page "https://github.com/git-lfs/gitobj")
+ (synopsis "Read and write git objects")
+ (description
+ "This package reads and writes loose and packed (objects found in git
+packfiles) Git objects. It uses the pack package to search pack index files
+and locate the corresponding delta-base chain in the appropriate pack file.
+If gitobj can't find a loose object with the appropriate SHA-1, it will search
+the repository's packfile(s) instead. If it finds an object in a packfile, it
+will reconstruct the object along its delta-base chain and return it.")
+ (license license:expat)))
+
(define-public git-lfs
(package
(name "git-lfs")