aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-20 00:05:21 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-20 00:05:21 +0100
commit24d4d6fdd67561e0de4b1cea6380e43e63d69646 (patch)
tree9c3f946b6e7c3d67af44cdcd9710ad8320e90080 /gnu/packages/valgrind.scm
parent92982ecca4efe857666d8b94ad95d2cc7d2ab54b (diff)
parenta512bbd23a2e129cf3d8e71255d504ce8bac77d3 (diff)
downloadguix-24d4d6fdd67561e0de4b1cea6380e43e63d69646.tar.gz
guix-24d4d6fdd67561e0de4b1cea6380e43e63d69646.zip
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index ee39bb2fb0..06622548a5 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Denis Carikli <GNUtoo@cyberdimension.org>
@@ -85,7 +85,7 @@ management and threading bugs, and profile your programs in detail. You can
also use Valgrind to build new tools.")
;; https://valgrind.org/info/platforms.html
(supported-systems (fold delete %supported-systems
- '("armhf-linux" "riscv64-linux")))
+ '("i586-gnu" "armhf-linux" "riscv64-linux")))
(license gpl2+)
;; Hide this variant so end users get the "interactive" Valgrind below.
@@ -96,5 +96,5 @@ also use Valgrind to build new tools.")
valgrind
(inputs
;; GDB is needed to provide a sane default for `--db-command'.
- (list gdb `(,(canonical-package glibc) "debug")))
+ (list gdb `(,(canonical-package (libc-for-target)) "debug")))
(properties '())))