aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/tor.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
downloadguix-8c3e9da13a3c92a7db308db8c0d81cb474ad7799.tar.gz
guix-8c3e9da13a3c92a7db308db8c0d81cb474ad7799.zip
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm72
1 files changed, 43 insertions, 29 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index cc11255a24..40f941fcea 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2018, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2018, 2019, 2021 Eric Bavier <bavier@posteo.net>
@@ -28,6 +28,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages tor)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -57,44 +58,57 @@
(define-public tor
(package
(name "tor")
- (version "0.4.6.10")
+ (version "0.4.7.7")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz"))
(sha256
(base32
- "077374vqk9mxi63viksq5zwn05i4xa2bqcihwwxz6n750h7ddk4l"))
- (patches (search-patches "tor-sandbox-i686.patch"))))
+ "0i2v3a2h7d0bjn64pi1c6h2x15lb53plf71xwkbkb51bnmc124ry"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list "--enable-lzma"
- "--enable-zstd")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'skip-practracker
- ;; This is a style linter. It doesn't get to throw fatal errors.
- (lambda _
- (setenv "TOR_DISABLE_PRACTRACKER" "set")))
- ,@(if (or (target-aarch64?)
- (target-ppc32?))
- ;; Work around upstream issue relating to sandboxing and glibc-2.33.
- ;; This is similar to the issue the tor-sandbox-i686 patch fixes
- ;; but for other architectures.
- ;; https://gitlab.torproject.org/tpo/core/tor/-/issues/40381
- ;; https://gitlab.torproject.org/tpo/core/tor/-/merge_requests/446
- `((add-before 'check 'adjust-test-suite
+ (list #:configure-flags
+ #~(list "--enable-lzma"
+ "--enable-zstd")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'adjust-torify
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Record in 'torify' the absolute file name of 'torsocks'.
+ (let ((torsocks (search-input-file
+ inputs "/bin/torsocks")))
+ (substitute* "contrib/client-tools/torify"
+ (("pathfind torsocks")
+ "true")
+ (("exec torsocks")
+ (string-append "exec " torsocks))))))
+ (add-before 'check 'skip-practracker
+ ;; This is a style linter. It doesn't get to throw fatal errors.
(lambda _
- (substitute* "src/test/test_include.sh"
- ((".*Sandbox 1.*") "")))))
- '()))))
+ (setenv "TOR_DISABLE_PRACTRACKER" "set")))
+ #$@(if (or (target-x86-64?)
+ (target-x86-32?))
+ '()
+ ;; Work around upstream issues relating to libseccomp,
+ ;; sandboxing and glibc-2.33. This is similar to the issue
+ ;; the tor-sandbox-i686 patch fixes but for other architectures.
+ ;; https://gitlab.torproject.org/tpo/core/tor/-/issues/40381
+ ;; https://gitlab.torproject.org/tpo/core/tor/-/issues/40599
+ ;; https://gitlab.torproject.org/tpo/core/tor/-/merge_requests/446
+ `((add-before 'check 'adjust-test-suite
+ (lambda _
+ (substitute* "src/test/test_include.sh"
+ ((".*Sandbox 1.*") ""))
+ (substitute* "src/test/test.c"
+ ((".*sandbox_tests.*") "")))))))))
(native-inputs
(list pkg-config python)) ; for tests
(inputs
(list libevent
libseccomp
openssl
+ torsocks
xz
zlib
`(,zstd "lib")))
@@ -121,9 +135,9 @@ instead.")
(name "tor-client")
(arguments
(substitute-keyword-arguments (package-arguments tor)
- ((#:configure-flags flags)
- (append flags
- '("--disable-module-relay")))))
+ ((#:configure-flags flags #~'())
+ #~(append #$flags
+ (list "--disable-module-relay")))))
(synopsis "Client to the anonymous Tor network")
(description
"Tor protects you by bouncing your communications around a distributed
@@ -441,14 +455,14 @@ Potential client and exit connections are scrubbed of sensitive information.")
(define-public tractor
(package
(name "tractor")
- (version "3.12")
+ (version "3.13")
(source
(origin
(method url-fetch)
(uri (pypi-uri "traxtor" version))
(sha256
(base32
- "0bwj4l6szvx7hpjr8va3hlv0g79sxz02hsb60l61hb314c6d4r3q"))))
+ "0r8zzaia1s678d39cpqjfpb72fwc46lfwnz1rb043hi6grd39jl7"))))
(build-system python-build-system)
(native-inputs
`(("glib:bin" ,glib "bin"))) ; for glib-compile-schemas.