aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 19:21:53 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:17 +0800
commit5bff04fdcb853cd4b0364dd778af90e1f018ed1d (patch)
tree7a9d2eed9c6969dac583ab7aa2f110b07cadac81 /gnu/packages/tls.scm
parentc3dd859df6a72ef92569908d01087172d44d7a30 (diff)
downloadguix-5bff04fdcb853cd4b0364dd778af90e1f018ed1d.tar.gz
guix-5bff04fdcb853cd4b0364dd778af90e1f018ed1d.zip
gnu: kmag: Update to 24.05.2.
* gnu/packages/kde-utils.scm (kmag): Update to 24.05.2. [inputs]: Remove qtbase-5; add libqaccessibilityclient. [arguments]: Set #:qtbase to qtbase. Change-Id: I5a97c7015c7a4c9c56cb3fab085f0b33512987b3
Diffstat (limited to 'gnu/packages/tls.scm')
0 files changed, 0 insertions, 0 deletions
d class='none' style='width: 0.0%;'/>
1 files changed, 24 insertions, 17 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 69cb8c878b..d061935c8c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1076,9 +1076,15 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
(close-port port))
(invoke "make" "oldconfig"))))
(replace 'install
- (lambda _
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
(let ((moddir (string-append #$output "/lib/modules"))
- (dtbdir (string-append #$output "/lib/dtbs")))
+ (dtbdir (string-append #$output "/lib/dtbs"))
+ (make-flags
+ (append make-flags
+ (list "-j"
+ (if parallel-build?
+ (number->string (parallel-job-count))
+ "1")))))
;; Install kernel image, kernel configuration and link map.
(for-each (lambda (file) (install-file file #$output))
(find-files "." "^(\\.config|bzImage|zImage|Image\
@@ -1086,22 +1092,23 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
;; Install device tree files
(unless (null? (find-files "." "\\.dtb$"))
(mkdir-p dtbdir)
- (invoke "make" (string-append "INSTALL_DTBS_PATH=" dtbdir)
- "dtbs_install"))
+ (apply invoke "make"
+ (string-append "INSTALL_DTBS_PATH=" dtbdir)
+ "dtbs_install" make-flags))
;; Install kernel modules
(mkdir-p moddir)
- (invoke "make"
- ;; Disable depmod because the Guix system's module
- ;; directory is an union of potentially multiple
- ;; packages. It is not possible to use depmod to
- ;; usefully calculate a dependency graph while
- ;; building only one of them.
- "DEPMOD=true"
- (string-append "MODULE_DIR=" moddir)
- (string-append "INSTALL_PATH=" #$output)
- (string-append "INSTALL_MOD_PATH=" #$output)
- "INSTALL_MOD_STRIP=1"
- "modules_install")
+ (apply invoke "make"
+ ;; Disable depmod because the Guix system's module
+ ;; directory is an union of potentially multiple
+ ;; packages. It is not possible to use depmod to
+ ;; usefully calculate a dependency graph while building
+ ;; only one of them.
+ "DEPMOD=true"
+ (string-append "MODULE_DIR=" moddir)
+ (string-append "INSTALL_PATH=" #$output)
+ (string-append "INSTALL_MOD_PATH=" #$output)
+ "INSTALL_MOD_STRIP=1"
+ "modules_install" make-flags)
(let* ((versions (filter (lambda (name)
(not (string-prefix? "." name)))
(scandir moddir)))
@@ -1123,7 +1130,7 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
elfutils ;needed to enable CONFIG_STACK_VALIDATION
flex
bison
- util-linux ;needed for hexdump
+ util-linux ;needed for hexdump
;; These are needed to compile the GCC plugins.
gmp
mpfr