aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-29 11:11:12 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-29 11:12:09 +0800
commit579fc6168921362bc1b251c43b39ba5e2ee9db6a (patch)
tree394fe0b5f5fcf23192a85ab201a6df09d9291a6b /gnu/packages/textutils.scm
parentde25a21433bf8ac213302c52789af06a37f4f972 (diff)
downloadguix-579fc6168921362bc1b251c43b39ba5e2ee9db6a.tar.gz
guix-579fc6168921362bc1b251c43b39ba5e2ee9db6a.zip
gnu: ascii2binary: Fix cross-compilation.
* gnu/packages/textutils.scm (ascii2binary): Fix cross-compilation. [native-inputs]: Add autoconf, automake. [arguments]: Add fix-rpl_malloc phase. Change-Id: Iefaca353490a17f9263431f60db33218a22e914c
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index b7ed686371..fb1fc088de 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -441,7 +441,18 @@ input bits thoroughly but are not suitable for cryptography.")
(base32 "0dc9fxcdmppbs9s06jvq61zbk552laxps0xyk098gj41697ihd96"))))
(build-system gnu-build-system)
(native-inputs
- (list gettext-minimal))
+ (list gettext-minimal autoconf automake))
+ (arguments (list #:phases
+ #~(modify-phases %standard-phases
+ ;; AC_FUNC_MALLOC and AC_FUNC_REALLOC usually unneeded
+ ;; see https://lists.gnu.org/archive/html/autoconf/2003-02/msg00017.html
+ (add-after 'unpack 'fix-rpl_malloc
+ (lambda _
+ (substitute* "configure.ac"
+ (("AC_FUNC_MALLOC") "")
+ (("AC_FUNC_REALLOC") ""))
+ ;; let bootstrap phase run.
+ (delete-file "./configure"))))))
(home-page "https://billposer.org/Software/a2b.html")
(synopsis "Convert between ASCII, hexadecimal and binary representations")
(description "The two programs are useful for generating test data, for