aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-13 17:21:32 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-13 17:21:32 +0200
commit15406013fe63f2ab238eec2d7a8adbc586806ac8 (patch)
tree8377d7c70a925f7c5ea4c04473c4eb547610b64b /gnu/packages/textutils.scm
parenta3ac317ab4a90f66ac65055fa26dee58ed2367b8 (diff)
parentdd4c1992103a65b8fbdc80fe07a9fe9be822769a (diff)
downloadguix-15406013fe63f2ab238eec2d7a8adbc586806ac8.tar.gz
guix-15406013fe63f2ab238eec2d7a8adbc586806ac8.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm30
1 files changed, 1 insertions, 29 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 026264dc27..51df3748cd 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -249,7 +249,7 @@ encoding, supporting Unicode version 9.0.0.")
(sha256
(base32 "1g77s8g9443dd92f82pbkim7rk51s7xdwa3mxpzb1lcw8ryxvvg3"))))
;; For tests
- ("ruby" ,ruby)))))))
+ ("ruby" ,ruby-2.7)))))))
(define-public libconfuse
(package
@@ -1008,34 +1008,6 @@ and Cython.")
markup and converts it to multiple formats.")
(license license:gpl2)))
-(define-public go-github.com-mattn-go-runewidth
- (let ((commit "703b5e6b11ae25aeb2af9ebb5d5fdf8fa2575211")
- (version "0.0.4")
- (revision "1"))
- (package
- (name "go-github.com-mattn-go-runewidth")
- (version (git-version version revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/runewidth")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0znpyz71gajx3g0j2zp63nhjj2c07g16885vxv4ykwnrfmzbgk4w"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/mattn/go-runewidth"))
- (synopsis "@code{runewidth} provides Go functions to work with string widths")
- (description
- "The @code{runewidth} library provides Go functions for padding,
-measuring and checking the width of strings, with support for East Asian
-text.")
- (home-page "https://github.com/mattn/runewidth")
- (license license:expat))))
-
(define-public docx2txt
(package
(name "docx2txt")