aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
commit533a893cc6b03f100566760d6e0c8e0500ed7082 (patch)
tree0ecbf89895a400c43d16bb1f6539f1a88aeaa4cf /gnu/packages/text-editors.scm
parent6a2546f92d07df04e5d700924edd027ed1e2ef11 (diff)
parentc762df54786fd6f005f3b5307323f1d2df3cbf0b (diff)
downloadguix-533a893cc6b03f100566760d6e0c8e0500ed7082.tar.gz
guix-533a893cc6b03f100566760d6e0c8e0500ed7082.zip
Merge branch 'master' into staging
Conflicts: .guix-authorizations gnu/ci.scm gnu/packages/base.scm gnu/packages/databases.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/imagemagick.scm gnu/packages/password-utils.scm gnu/packages/python-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9e81333865..3af1aec94b 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -80,15 +80,15 @@
(define-public vis
(package
(name "vis")
- (version "0.6") ; also update the vis-test input
+ (version "0.7") ; also update the vis-test input
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/martanne/vis")
+ (url "https://git.sr.ht/~martanne/vis")
(commit (string-append "v" version))))
(sha256
- (base32 "1zjm89cn3rfq8fxpwp66khy53s6vqlmw6q103qyyvix8ydzxdmsh"))
+ (base32 "1g05ncsnk57kcqm9wsv6sz8b24kyzj8r5rfpa1wfwj8qkjzx3vji"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -136,10 +136,10 @@
,(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/martanne/vis-test")
- (commit "4c4f6645de77f697a45899e8645e0c2bbdc7208a")))
+ (url "https://git.sr.ht/~martanne/vis-test")
+ (commit "bbd2f34ff788e87a51a74069069273ad83c44f1f")))
(sha256
- (base32 "10vh1pxsqw88a5xwh5irkm85xr66dbycmgpmabyw9h0vm14cvcz2"))
+ (base32 "1jsvg2lg3xqfgi79x08kx94mc34mh62ivca10vsci6fqsk68jbd0"))
(file-name (git-file-name "vis-test" version))))))
(inputs `(("lua" ,lua)
("ncurses" ,ncurses)
@@ -600,16 +600,17 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
(define-public ghostwriter
(package
(name "ghostwriter")
- (version "1.8.1")
+ ;; XXX We use a release candidate to fix incompatibility with Qt 5.15.
+ (version "2.0.0-rc4")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/wereturtle/ghostwriter")
- (commit (string-append "v" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "0jc6szfh5sdnafhwsr1xv7cn1fznniq58bix41hb9wlbkvq7wzi6"))))
+ "07547503a209hc0fcg902w3x0s1m899c10nj3gqz3hak0cmrasi3"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -805,14 +806,14 @@ editors.")
(define-public texmacs
(package
(name "texmacs")
- (version "1.99.18")
+ (version "1.99.19")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.texmacs.org/Download/ftp/tmftp/"
"source/TeXmacs-" version "-src.tar.gz"))
(sha256
- (base32 "0il3fwgw20421aj90wg8kyhkwk6lbgb3bb2g5qamh5lk90yj725i"))))
+ (base32 "1izwqb0z4gqiglv57mjswk6sjivny73kd2sxrf3nmj7wr12pn5m8"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -964,7 +965,7 @@ The basic features of Geany are:
(define-public fe
(package
(name "fe")
- ;; Stable release is 1.8. However, this development version
+ ;; Stable release is 1.9. However, this development version
;; introduces support for UTF-8.
(version "2.0")
(source (origin
@@ -973,7 +974,7 @@ The basic features of Geany are:
"fe-" version ".tar.gz"))
(sha256
(base32
- "1hwws7si1752z6hp61zxznvgsb6846lp8zl1hn5ddhsbafwalwb9"))))
+ "10mk5wc3dsdp46b3hkjyd740gcdv6m1gvlr3p8xjxf55b3vfs0la"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no test
@@ -1046,7 +1047,7 @@ card. It offers:
(substitute* "src/makefile"
(("-lcurses") "-lncurses"))
#t)))))
- (home-page "http://ne.di.unimi.it/")
+ (home-page "https://ne.di.unimi.it/")
(synopsis "Text editor with menu bar")
(description "This package provides a modeless text editor with menu bar.
It supports syntax highlighting, regular expressions, configurable menus,