aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:50:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:28 +0200
commitf4e823f17c5d23957160dd100187e41ae51b77b3 (patch)
tree6740a7dea642b5aeb82bfb653740576534621988 /gnu/packages/tex.scm
parent5df0245cc7ae28f2fba70438336beac14379ef5c (diff)
downloadguix-f4e823f17c5d23957160dd100187e41ae51b77b3.tar.gz
guix-f4e823f17c5d23957160dd100187e41ae51b77b3.zip
gnu: Add texlive-fltpoint.
* gnu/packages/tex.scm (texlive-fltpoint): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b5ed30db9f..9fc2109abc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2561,6 +2561,26 @@ referenced.")
to apply to page dimensions.")
(license license:public-domain)))
+(define-public texlive-fltpoint
+ (package
+ (name "texlive-fltpoint")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/fltpoint/"
+ "source/generic/fltpoint/"
+ "tex/generic/fltpoint/")
+ (base32
+ "0k85cyh39rxr3jrgyxcj1lrya5zss5da62pj7q8412naaklkhd7n")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/fltpoint")
+ (synopsis "Simple floating point arithmetic")
+ (description
+ "The package provides simple floating point operations (addition,
+subtraction, multiplication, division and rounding).")
+ (license license:lppl1.2+)))
+
(define-public texlive-fontools
(package
(name "texlive-fontools")