aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 09:56:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:30 +0200
commitead4e6b7b84dfa75cb568a3b95e5605dfdc7b1bd (patch)
treedcf4243ba1ff2bccf546c76823b0d487f702550a /gnu/packages/tex.scm
parent8b495d5f775106b3c5630862bcb5801273e35fee (diff)
downloadguix-ead4e6b7b84dfa75cb568a3b95e5605dfdc7b1bd.tar.gz
guix-ead4e6b7b84dfa75cb568a3b95e5605dfdc7b1bd.zip
gnu: Add texlive-ctanbib.
* gnu/packages/tex.scm (texlive-ctanbib): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 87d947514d..40d4917ced 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1479,6 +1479,28 @@ files/projects. It is completely open for users to program additional
guidelines as well as CTAN's future adjustments.")
(license license:gpl3)))
+(define-public texlive-ctanbib
+ (package
+ (name "texlive-ctanbib")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/ctanbib.1"
+ "doc/man/man1/ctanbib.man1.pdf"
+ "doc/support/ctanbib/" "scripts/ctanbib/")
+ (base32
+ "0vlx37g8mp8rqb744bngykzh8yszscw2vlv7n78c8ymagx2c1xpf")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "ctanbib")))
+ (home-page "https://ctan.org/pkg/ctanbib")
+ (synopsis "Export CTAN entries to bib format")
+ (description
+ "This package provides a Lua script which can be used for retrieving
+bibliographic information in BibLaTeX format for packages hosted on CTAN. The
+@command{ctanbib} script depends only on LuaXML.")
+ (license license:lppl1.3+)))
+
(define-public texlive-dvipsconfig
(package
(name "texlive-dvipsconfig")