aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:48:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:30 +0200
commitdf388e75b8e2513ca7dcec4dac02d24500343ac4 (patch)
treeb7e476d69119a362cffb7e22a4ae60b678622c3e /gnu/packages/tex.scm
parentbc27694a88cc6b95fd675d9031298e18d3fbccb2 (diff)
downloadguix-df388e75b8e2513ca7dcec4dac02d24500343ac4.tar.gz
guix-df388e75b8e2513ca7dcec4dac02d24500343ac4.zip
gnu: Add texlive-rrgtrees.
* gnu/packages/tex.scm (texlive-rrgtrees): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2d0a6affa2..bffc59436e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11157,6 +11157,29 @@ package solves the problem by extending ideas described in M. I. Grinchuk
mathematical packages.")
(license license:lppl1.3+)))
+(define-public texlive-rrgtrees
+ (package
+ (name "texlive-rrgtrees")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/rrgtrees/"
+ "source/latex/rrgtrees/"
+ "tex/latex/rrgtrees/")
+ (base32
+ "0h33q32pb1s8zv598aacdzfhpk2psrzxgxnav6am16cxfri60hpi")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/rrgtrees")
+ (synopsis
+ "Linguistic tree diagrams for Role and Reference Grammar (RRG) with LaTeX")
+ (description
+ "This package provides a set of LaTeX macros that makes it easy to
+produce linguistic tree diagrams suitable for Role and Reference
+Grammar (RRG). This package allows the construction of trees with crossing
+lines, as is required by this theory for many languages.")
+ (license license:lppl)))
+
(define-public texlive-sankey
(package
(name "texlive-sankey")