aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:38:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:39 +0200
commitd8cb19a814913653007b2df0869ea071b644eaaa (patch)
tree1617bfd9a138323310c6ac9799b3cb79d52617eb /gnu/packages/tex.scm
parent4e6c50ebb1139121355fbe90329be35575ea17e1 (diff)
downloadguix-d8cb19a814913653007b2df0869ea071b644eaaa.tar.gz
guix-d8cb19a814913653007b2df0869ea071b644eaaa.zip
gnu: Add texlive-octave.
* gnu/packages/tex.scm (texlive-octave): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0ba7d18f97..d41b65f08d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10543,6 +10543,26 @@ mathematical function values.")
"The package will typeset both Z and Object-Z specifications.")
(license license:lppl)))
+(define-public texlive-octave
+ (package
+ (name "texlive-octave")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/octave/" "tex/latex/octave/")
+ (base32
+ "1avikh00n92lxk7p7h0kvsv2dk2z411fv85fagj7bg6azb3fch8g")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/octave")
+ (synopsis "Typeset musical pitches with octave designations")
+ (description
+ "This package package typesets musical pitch names with designation for
+the octave in either the Helmholtz system (with octave numbers), or the
+traditional system (with prime symbols). The system can also be changed
+mid-document.")
+ (license license:lppl1.3+)))
+
(define-public texlive-omega
(package
(name "texlive-omega")