aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:30:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:23 +0200
commitd563f4ddda44c6aedae6766f3086a62f588ff75e (patch)
treef35a15cc840e026da360713c6b531b3e6967d1d8 /gnu/packages/tex.scm
parent8dfc0737266e71a3056aebc068d1d3955330ed66 (diff)
downloadguix-d563f4ddda44c6aedae6766f3086a62f588ff75e.tar.gz
guix-d563f4ddda44c6aedae6766f3086a62f588ff75e.zip
gnu: Add texlive-ecltree.
* gnu/packages/tex.scm (texlive-ecltree): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f1fda22568..64501bbb9e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5397,6 +5397,25 @@ Gaulle (now deceased), under a free licence. It replaces the old full
to the PGF mathematical engine.")
(license license:lppl1.3+)))
+(define-public texlive-ecltree
+ (package
+ (name "texlive-ecltree")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ecltree/" "tex/latex/ecltree/")
+ (base32
+ "0ki5zzpl8dkz7zwyccmsxfnfq7vl5vlx3gi1py64mgqxfxp0rivw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ecltree")
+ (synopsis "Trees using Epic and Eepic macros")
+ (description
+ "The package recursively draws trees: each subtree is defined in
+a @code{bundle} environment, with a set of leaves described by @code{\\chunk}
+macros. A chunk may have a @code{bundle} environment inside it.")
+ (license license:lppl)))
+
(define-public texlive-econometrics
(package
(name "texlive-econometrics")