aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:45:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:29 +0200
commitbfe5ea96e57f5337015ebb59630cecc4a1610ccd (patch)
tree3f0d302c15d2a3d332231ecc2075ea0f9409c5ae /gnu/packages/tex.scm
parentf00bf64f79df3d38dc7846058dfd4925905c6e0e (diff)
downloadguix-bfe5ea96e57f5337015ebb59630cecc4a1610ccd.tar.gz
guix-bfe5ea96e57f5337015ebb59630cecc4a1610ccd.zip
gnu: Add texlive-poetry.
* gnu/packages/tex.scm (texlive-poetry): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 614b0ef61b..69d37eea64 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10559,6 +10559,29 @@ sections, index of titles and first lines, and automatic generation of a table
of contents.")
(license license:lppl1.3c)))
+(define-public texlive-poetry
+ (package
+ (name "texlive-poetry")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/poetry/" "source/latex/poetry/"
+ "tex/latex/poetry/")
+ (base32
+ "1z262am0qh6h1qqf36hxj2lc7d5pr4r65yx8ysrydh0sijccgild")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/poetry")
+ (synopsis "Facilities for typesetting poetry and poetical structure")
+ (description
+ "This package provides some macros and general doodads for typesetting poetry.
+There is, of course, already the excellent @code{verse} package, and the
+@code{poetrytex} package provides some extra functionality on top of it. But
+@code{poetry} provides much of the same functionality in a bit of a different
+way, and with a few additional abilities, such as facilities for a list of
+poems, an index of first lines, and some structural commands.")
+ (license license:lppl1.3c)))
+
(define-public texlive-polexpr
(package
(name "texlive-polexpr")