aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 00:35:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:40:10 +0200
commit8e81964a8b777a815999d74a2ec5cdf93fb23557 (patch)
treebbbd3250a4e73b85384196feb72fceee3206c55b /gnu/packages/tex.scm
parent6f321c0de458628f23c9cb6457c9bfe35250024c (diff)
downloadguix-8e81964a8b777a815999d74a2ec5cdf93fb23557.tar.gz
guix-8e81964a8b777a815999d74a2ec5cdf93fb23557.zip
gnu: Add texlive-scheme-medium.
* gnu/packages/tex.scm (texlive-scheme-medium): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a2e4ac51f5..c6e85d08a6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -903,6 +903,42 @@ mathematical or other technical packages.")
(description "This is the TeX Live scheme for installing ConTeXt.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-scheme-medium
+ (package
+ (name "texlive-scheme-medium")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-collection-basic
+ texlive-collection-binextra
+ texlive-collection-context
+ texlive-collection-fontsrecommended
+ texlive-collection-fontutils
+ texlive-collection-langczechslovak
+ texlive-collection-langenglish
+ texlive-collection-langeuropean
+ texlive-collection-langfrench
+ texlive-collection-langgerman
+ texlive-collection-langitalian
+ texlive-collection-langpolish
+ texlive-collection-langportuguese
+ texlive-collection-langspanish
+ texlive-collection-latex
+ texlive-collection-latexrecommended
+ texlive-collection-luatex
+ texlive-collection-mathscience
+ texlive-collection-metapost
+ texlive-collection-plaingeneric
+ texlive-collection-xetex))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "Small scheme with additional packages and languages")
+ (description
+ "This is the medium TeX Live collection: it contains plain TeX,
+LaTeX, many recommended packages, and support for most European languages.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-scheme-minimal
(package
(name "texlive-scheme-minimal")