aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:34:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:38 +0200
commit61b78edef0cc8817e1a1edc45a234c7ff67f6492 (patch)
treefc4b228d38a588be261d0031010df88f2d70564b /gnu/packages/tex.scm
parent4a056ade5b59c15e69eaf12669ad5d793bf9b127 (diff)
downloadguix-61b78edef0cc8817e1a1edc45a234c7ff67f6492.tar.gz
guix-61b78edef0cc8817e1a1edc45a234c7ff67f6492.zip
gnu: Add texlive-lilyglyphs.
* gnu/packages/tex.scm (texlive-lilyglyphs): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d4077bee33..5ab9064ab7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8420,6 +8420,38 @@ simple roots of any complex simple Lie algebra. It uses the Dynkin diagrams
package @code{dynkin-diagrams}.")
(license license:lppl1.3c)))
+(define-public texlive-lilyglyphs
+ (package
+ (name "texlive-lilyglyphs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/lilyglyphs/"
+ "fonts/opentype/public/lilyglyphs/"
+ "scripts/lilyglyphs/"
+ "source/latex/lilyglyphs/fonts/"
+ "source/latex/lilyglyphs/glyphimages/definitions/"
+ "source/latex/lilyglyphs/glyphimages/generated_src/"
+ "tex/latex/lilyglyphs/")
+ (base32
+ "1g5v2bq7ml9pnh2xlkzf6k9zh3azw7i96iapp8yajyxk8akj0ki2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:link-scripts
+ #~(list "lily-glyph-commands.py"
+ "lily-image-commands.py"
+ "lily-rebuild-pdfs.py")))
+ (inputs (list python))
+ (home-page "https://ctan.org/pkg/lilyglyphs")
+ (synopsis "Access Lilypond fragments and glyphs, in LaTeX")
+ (description
+ "The package provides the means to include arbitrary elements of LilyPond
+notation, including symbols from Lilypond's Emmentaler font, in a LaTeX
+document. The package uses OpenType fonts, and as a result must be compiled
+with LuaLaTeX or XeLaTeX.")
+ (license license:lppl1.3c)))
+
(define-public texlive-ling-macros
(package
(name "texlive-ling-macros")