aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:36:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:25 +0200
commit4281befe4a541093ff5d9bb8fe83f73093f7f6aa (patch)
tree8eee17fda584bd156ffd955720b27c0b3d6579fa /gnu/packages/tex.scm
parent4f6365534bf36df2a92e8a78e54f5f62720a02ec (diff)
downloadguix-4281befe4a541093ff5d9bb8fe83f73093f7f6aa.tar.gz
guix-4281befe4a541093ff5d9bb8fe83f73093f7f6aa.zip
gnu: Add texlive-langnames.
* gnu/packages/tex.scm (texlive-langnames): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0c9b5a0557..768e417dc4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7822,6 +7822,30 @@ and commands.")
(description "This is LaTeX for Omega and Aleph.")
(license license:lppl1.0+)))
+(define-public texlive-langnames
+ (package
+ (name "texlive-langnames")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/langnames/"
+ "source/latex/langnames/"
+ "tex/latex/langnames/")
+ (base32
+ "0fi2xfy33d970g8wdnzasqdzgjcj7rkss9y7pzsp89z1hij3d1z2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/langnames")
+ (synopsis "Name languages and their genetic affiliations consistently")
+ (description
+ "This package attempts to make the typing of language names, codes, and
+families slightly easier by providing macros to access pre-defined
+language --- code --- family combinations from two important databases, as
+well as the possibility to create new combinations. It may be particularly
+useful for large, collaborative projects as well as typologically minded ones
+with a variety of language examples.")
+ (license license:lppl1.3+)))
+
(define-public texlive-latex-notes-zh-cn
(package
(name "texlive-latex-notes-zh-cn")