aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:36:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:38 +0200
commit283c2c258df4641dfc534537e740de3f3e94a51f (patch)
treed030361cafad00b2f3078bccda26c4a8b7077aa1 /gnu/packages/tex.scm
parent0c632dcd4478ebfbdec436d44556166d2d7dbacf (diff)
downloadguix-283c2c258df4641dfc534537e740de3f3e94a51f.tar.gz
guix-283c2c258df4641dfc534537e740de3f3e94a51f.zip
gnu: Add texlive-musical.
* gnu/packages/tex.scm (texlive-musical): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 20a85ee103..f906cf2234 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9899,6 +9899,29 @@ related to multiobjective optimisation, multiobjective evolutionary
algorithms, multicriteria decision making and similar fields.")
(license license:lppl)))
+(define-public texlive-musical
+ (package
+ (name "texlive-musical")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/musical/" "tex/latex/musical/")
+ (base32
+ "0qdrd622vs5dkr5w6pvf04hvni1jqcgxfvhf0ak7gjaxjczisb9h")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/musical")
+ (synopsis "Typeset (musical) theatre scripts")
+ (description
+ "This package is designed to simplify the development and distribution of
+scripts for theatrical musicals, especially ones under development. The
+output is formatted to follow generally accepted script style while also
+maintaining a high level of typographic integrity, and includes commands for
+dialog, lyrics, stage directions, music and dance cues, rehearsal marks, and
+more. It gracefully handles dialog that crosses page breaks, and can generate
+lists of songs and lists of dances in the show.")
+ (license license:lppl1.3+)))
+
(define-public texlive-musixtex
(package
(name "texlive-musixtex")