aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:45:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:41 +0200
commit1b2d43fe016848ea2ec16ff18cbc14340944fc4e (patch)
tree4f2ab0fba675091b4be908a875fa588e9b3fb3cd /gnu/packages/tex.scm
parent36a25b75a192bea373b25cc0e4f5e309b6f9a808 (diff)
downloadguix-1b2d43fe016848ea2ec16ff18cbc14340944fc4e.tar.gz
guix-1b2d43fe016848ea2ec16ff18cbc14340944fc4e.zip
gnu: Add texlive-collection-music.
* gnu/packages/tex.scm (texlive-collection-music): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6176ecc891..d01c31e7db 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -46392,6 +46392,55 @@ science packages.")
with packages in @code{collection-basic}.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-collection-music
+ (package
+ (name "texlive-collection-music")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-abc
+ texlive-autosp
+ texlive-bagpipe
+ texlive-chordbars
+ texlive-chordbox
+ texlive-collection-latex
+ texlive-ddphonism
+ texlive-figbas
+ texlive-gchords
+ texlive-gregoriotex
+ texlive-gtrcrd
+ texlive-guitar
+ texlive-guitarchordschemes
+ texlive-guitartabs
+ texlive-harmony
+ texlive-latex4musicians
+ texlive-leadsheets
+ texlive-lilyglyphs
+ texlive-lyluatex
+ texlive-m-tx
+ texlive-musical
+ texlive-musicography
+ texlive-musixguit
+ texlive-musixtex
+ texlive-musixtex-fonts
+ texlive-musixtnt
+ texlive-octave
+ texlive-piano
+ texlive-pmx
+ texlive-pmxchords
+ texlive-recorder-fingering
+ texlive-songbook
+ texlive-songproj
+ texlive-songs
+ texlive-xml2pmx
+ texlive-xpiano))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "Music packages")
+ (description "This collection includes music-related fonts and packages.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-collection-pictures
(package
(name "texlive-collection-pictures")