aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:55:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:35 +0200
commit0f26b7d2f015c586d648b7bbf2bcf70e2686e268 (patch)
treee3036961c583517a2d60b4e240031c8b11dd429b /gnu/packages/tex.scm
parent3342f91035e1a5f49a8f54970b8c1e7822359f75 (diff)
downloadguix-0f26b7d2f015c586d648b7bbf2bcf70e2686e268.tar.gz
guix-0f26b7d2f015c586d648b7bbf2bcf70e2686e268.zip
gnu: Add texlive-metatex.
* gnu/packages/tex.scm (texlive-metatex): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6f88c45b3f..20b9a20581 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3070,6 +3070,28 @@ providing a mechanism for local allocation. The package works with Plain TeX
and LaTeX.")
(license license:knuth)))
+(define-public texlive-metatex
+ (package
+ (name "texlive-metatex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/plain/metatex/" "tex/plain/metatex/")
+ (base32
+ "0pdgx59ckp9qdfidl37y8mv3dyvza9lxmhgbqk69ckywm3kbb2n9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/metatex")
+ (synopsis "Incorporate Metafont pictures in TeX source")
+ (description
+ "METATeX is a set of plain TeX and Metafont macros that you can use to
+define both the text and the figures in a single source file. Because METATeX
+sets up two way communication, from TeX to Metafont and back from Metafont to
+TeX, drawing dimensions can be controlled by TeX and labels can be located by
+Metafont. Only standard features of TeX and Metafont are used, but two runs
+of TeX and one of Metafont are needed.")
+ (license license:gpl3+)))
+
(define-public texlive-tex
(package
(name "texlive-tex")