aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/terminals.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
downloadguix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.tar.gz
guix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.zip
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 6fb2684326..60ea8e993e 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -115,6 +115,7 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -255,8 +256,8 @@ managers.")
(substitute* "tests/pty_test.py"
(("python3") (search-input-file inputs "/bin/python3"))))))))
(native-inputs
- ;; For tests.
- (list python-pytest))
+ (list python-pytest ; For tests.
+ python-setuptools python-wheel))
(home-page "https://asciinema.org")
(synopsis "Terminal session recorder")
(description