aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-22 10:55:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-22 10:55:46 +0100
commit9964fafffd440bd78152375b93661cc39152c1a2 (patch)
tree1ab68dd9ca08d7e32a4850778ccae7f1f0f70697 /gnu/packages/terminals.scm
parent2c7119b43bd44ee812ceaa2351bff9a8b623a920 (diff)
parente5911372ccc5482aceaf115bd30ce03dcbe00667 (diff)
downloadguix-9964fafffd440bd78152375b93661cc39152c1a2.tar.gz
guix-9964fafffd440bd78152375b93661cc39152c1a2.zip
Merge remote-tracking branch 'origin/go-team'
Change-Id: Ie1a29192d144a59394bbacba3f6b9f110413e821
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index f3e9e0c6d9..7b99b9672e 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1019,30 +1019,28 @@ programmer to write text-based user interfaces.")
(define-public go-github-com-junegunn-fzf
(package
(name "go-github-com-junegunn-fzf")
- (version "0.41.0")
+ (version "0.54.3")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/junegunn/fzf")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1l9nsvziip3azyvg8wi4g3x606fh6w9vpfcbcgjdzdnp2ywqciim"))))
+ "0mdj3z7w2igkvy8r304k9rcr2l6xm459ifshdm55iy6mazd8cmci"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/junegunn/fzf"))
(inputs
- (list go-github-com-mattn-go-runewidth
- go-github-com-mattn-go-shellwords
+ (list go-github-com-charlievieth-fastwalk
+ go-github-com-gdamore-tcell-v2
go-github-com-mattn-go-isatty
- go-github-com-gdamore-tcell
+ go-github-com-mattn-go-shellwords
go-github-com-rivo-uniseg
- go-github-com-saracen-walker
- go-golang-org-x-sync
- go-golang-org-x-term
- go-golang-org-x-crypto))
+ go-golang-org-x-sys
+ go-golang-org-x-term))
(home-page "https://github.com/junegunn/fzf")
(synopsis "Command-line fuzzy-finder")
(description "This package provides an interactive command-line filter