aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-09 12:22:14 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-09 12:22:14 +0200
commit94ca5b4357af8f8921f0cb0873a7cf316f13aa69 (patch)
tree6ef30120737f26f298f7f17d86597b0b729517e0 /gnu/packages/terminals.scm
parent6750c114e3e988249f4069d0180316c6d0192350 (diff)
parentdb61bdd7f52270a35bd0a3a88650d98276dab20b (diff)
downloadguix-94ca5b4357af8f8921f0cb0873a7cf316f13aa69.tar.gz
guix-94ca5b4357af8f8921f0cb0873a7cf316f13aa69.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm77
1 files changed, 77 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index c59b1a6588..43aeac9fd7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -100,6 +101,7 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -1158,6 +1160,81 @@ terminal. It features string-like objects which carry formatting information,
per-line fullscreen terminal rendering, and keyboard input event reporting.")
(license license:expat)))
+(define-public python-halo
+ (package
+ (name "python-halo")
+ (version "0.0.31")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "halo" version))
+ (sha256
+ (base32
+ "1mn97h370ggbc9vi6x8r6akd5q8i512y6kid2nvm67g93r9a6rvv"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-colorama python-log-symbols python-six
+ python-spinners python-termcolor))
+ (native-inputs (list python-coverage python-nose python-pylint python-tox
+ python-twine))
+ (home-page "https://github.com/manrajgrover/halo")
+ (synopsis "Python library to display graphical spinners in the terminal")
+ (description "Halo is a Python library to display graphical spinners in
+the terminal. It also supports IPython/Jupyter.")
+ (license license:expat)))
+
+(define-public python-log-symbols
+ (package
+ (name "python-log-symbols")
+ (version "0.0.14")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "log_symbols" version))
+ (sha256
+ (base32
+ "0mh5d0igw33libfmbsr1ri1p1y644p36nwaa2w6kzrd8w5pvq2yg"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "requirements-dev.txt"
+ (("(.*)==(.*)$" _ dep ver)
+ (string-append dep ">=" ver))))))))
+ (propagated-inputs (list python-colorama))
+ (native-inputs (list python-coverage python-nose python-pylint python-tox))
+ (home-page "https://github.com/manrajgrover/py-log-symbols")
+ (synopsis "Python library with graphical symbols for logging on the terminal")
+ (description "This package provides a Python library with graphical symbols
+that can be displayed on the terminal, with color if possible, for logging
+purposes.")
+ (license license:expat)))
+
+(define-public python-spinners
+ (package
+ (name "python-spinners")
+ (version "0.0.24")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "spinners" version))
+ (sha256
+ (base32
+ "0zz2z6dpdjdq5z8m8w8dfi8by0ih1zrdq0caxm1anwhxg2saxdhy"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "requirements-dev.txt"
+ (("(.*)==(.*)$" _ dep ver)
+ (string-append dep ">=" ver))))))))
+ (native-inputs (list python-coverage python-nose python-pylint python-tox))
+ (home-page "https://github.com/manrajgrover/py-spinners")
+ (synopsis "Python library with graphical spinners for the terminal")
+ (description "Spinners is a Python library that contains graphical spinners
+that can be displayed terminal.")
+ (license license:expat)))
+
(define-public tmate
(package
(name "tmate")