aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/terminals.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
downloadguix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.tar.gz
guix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.zip
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 60ea8e993e..1254d48741 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1232,8 +1232,14 @@ the terminal. It also supports IPython/Jupyter.")
(substitute* "requirements-dev.txt"
(("(.*)==(.*)$" _ dep ver)
(string-append dep ">=" ver))))))))
+ (native-inputs
+ (list python-coverage
+ python-nose
+ python-pylint
+ python-setuptools
+ python-tox
+ python-wheel))
(propagated-inputs (list python-colorama))
- (native-inputs (list python-coverage python-nose python-pylint python-tox))
(home-page "https://github.com/manrajgrover/py-log-symbols")
(synopsis "Python library with graphical symbols for logging on the terminal")
(description "This package provides a Python library with graphical symbols
@@ -1260,7 +1266,13 @@ purposes.")
(substitute* "requirements-dev.txt"
(("(.*)==(.*)$" _ dep ver)
(string-append dep ">=" ver))))))))
- (native-inputs (list python-coverage python-nose python-pylint python-tox))
+ (native-inputs
+ (list python-coverage
+ python-nose
+ python-pylint
+ python-setuptools
+ python-tox
+ python-wheel))
(home-page "https://github.com/manrajgrover/py-spinners")
(synopsis "Python library with graphical spinners for the terminal")
(description "Spinners is a Python library that contains graphical spinners